summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/hal-flash')
-rw-r--r--media-libs/hal-flash/Manifest1
-rw-r--r--media-libs/hal-flash/hal-flash-0.2.0_rc1.ebuild35
-rw-r--r--media-libs/hal-flash/metadata.xml11
3 files changed, 47 insertions, 0 deletions
diff --git a/media-libs/hal-flash/Manifest b/media-libs/hal-flash/Manifest
new file mode 100644
index 000000000000..270ad299f726
--- /dev/null
+++ b/media-libs/hal-flash/Manifest
@@ -0,0 +1 @@
+DIST libhal1-flash_0.2.0rc1.tar.gz 21363 SHA256 1ceb6d887b7bdd7e52c0296f3b4029d5237b87bdf02ac2bf53ddb5a4341800c7 SHA512 26731ef4c13176222c54bf39dd21704891ce75b0467559cecbe6c81ae2ac3c937b6f8d84b7df388bd4e7a43b94837d6b05391b5eab3893762faeb9875e53a2ff WHIRLPOOL f9f2562424acec685a903294b42eb1609026fc39d78fc742d20b076d53190aed1a8042394231828189f3c34075353f0141f7089c859e863bd22ceb4956fc8060
diff --git a/media-libs/hal-flash/hal-flash-0.2.0_rc1.ebuild b/media-libs/hal-flash/hal-flash-0.2.0_rc1.ebuild
new file mode 100644
index 000000000000..2e3eef356876
--- /dev/null
+++ b/media-libs/hal-flash/hal-flash-0.2.0_rc1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils
+
+MY_P=${PN/hal/libhal1}_${PV/_}
+
+DESCRIPTION="A libhal stub library forwarding to UDisks for www-plugins/adobe-flash to play DRM content"
+HOMEPAGE="http://github.com/cshorler/hal-flash http://build.opensuse.org/package/show/devel:openSUSE:Factory/hal-flash"
+SRC_URI="http://build.opensuse.org/package/rawsourcefile/devel:openSUSE:Factory/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+COMMON_DEPEND="sys-apps/dbus
+ !sys-apps/hal"
+RDEPEND="${COMMON_DEPEND}
+ sys-fs/udisks:0"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+
+DOCS="README"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() { eautoreconf; }
+
+src_install() {
+ default
+ prune_libtool_files
+}
diff --git a/media-libs/hal-flash/metadata.xml b/media-libs/hal-flash/metadata.xml
new file mode 100644
index 000000000000..51217b9ddfee
--- /dev/null
+++ b/media-libs/hal-flash/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>ssuominen@gentoo.org</email>
+ <name>Samuli Suominen</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">cshorler/hal-flash</remote-id>
+ </upstream>
+</pkgmetadata>