summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/cimg/cimg-3.2.4.ebuild')
-rw-r--r--media-libs/cimg/cimg-3.2.4.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/media-libs/cimg/cimg-3.2.4.ebuild b/media-libs/cimg/cimg-3.2.4.ebuild
new file mode 100644
index 000000000000..5ea343966cc1
--- /dev/null
+++ b/media-libs/cimg/cimg-3.2.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="C++ template image processing toolkit"
+HOMEPAGE="https://cimg.eu/ https://github.com/dtschump/CImg"
+SRC_URI="https://github.com/dtschump/CImg/archive/v.${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/CImg-v.${PV}"
+
+LICENSE="CeCILL-2 CeCILL-C"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+src_install() {
+ doheader CImg.h
+ dodoc README.txt
+
+ use doc && dodoc -r html
+ if use examples; then
+ dodoc -r examples
+ docompress -x "/usr/share/doc/${PF}/examples"
+ fi
+}