summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-util')
-rw-r--r--games-util/gamemode/gamemode-1.7.ebuild2
-rw-r--r--games-util/gamemode/gamemode-9999.ebuild2
2 files changed, 4 insertions, 0 deletions
diff --git a/games-util/gamemode/gamemode-1.7.ebuild b/games-util/gamemode/gamemode-1.7.ebuild
index 028fd6b39402..c54619d5b953 100644
--- a/games-util/gamemode/gamemode-1.7.ebuild
+++ b/games-util/gamemode/gamemode-1.7.ebuild
@@ -86,12 +86,14 @@ multilib_src_configure() {
if multilib_is_native_abi; then
emesonargs+=(
-Dwith-sd-bus-provider=$(usex systemd systemd elogind)
+ -Dwith-util=true
)
else
emesonargs+=(
-Dwith-sd-bus-provider=no-daemon
-Dwith-pam-group=gamemode
-Dwith-examples=false
+ -Dwith-util=false
)
fi
diff --git a/games-util/gamemode/gamemode-9999.ebuild b/games-util/gamemode/gamemode-9999.ebuild
index 9490fc1e7b56..5807b8187fbf 100644
--- a/games-util/gamemode/gamemode-9999.ebuild
+++ b/games-util/gamemode/gamemode-9999.ebuild
@@ -86,12 +86,14 @@ multilib_src_configure() {
if multilib_is_native_abi; then
emesonargs+=(
-Dwith-sd-bus-provider=$(usex systemd systemd elogind)
+ -Dwith-util=true
)
else
emesonargs+=(
-Dwith-sd-bus-provider=no-daemon
-Dwith-pam-renicing=false
-Dwith-examples=false
+ -Dwith-util=false
)
fi