summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-fps/alephone')
-rw-r--r--games-fps/alephone/alephone-20220115.ebuild7
-rw-r--r--games-fps/alephone/alephone-9999.ebuild7
2 files changed, 12 insertions, 2 deletions
diff --git a/games-fps/alephone/alephone-20220115.ebuild b/games-fps/alephone/alephone-20220115.ebuild
index 3b71a7f7c6ec..3fc299106b8f 100644
--- a/games-fps/alephone/alephone-20220115.ebuild
+++ b/games-fps/alephone/alephone-20220115.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit autotools optfeature prefix xdg
+inherit autotools optfeature prefix toolchain-funcs xdg
DESCRIPTION="An enhanced version of the game engine from the classic Mac game, Marathon"
HOMEPAGE="http://source.bungie.org/"
@@ -75,6 +75,11 @@ src_configure() {
$(use_with upnp miniupnpc)
}
+src_compile() {
+ tc-export AR
+ default
+}
+
src_install() {
default
prefixify_ro "${FILESDIR}"/${PN}.sh
diff --git a/games-fps/alephone/alephone-9999.ebuild b/games-fps/alephone/alephone-9999.ebuild
index 3b71a7f7c6ec..3fc299106b8f 100644
--- a/games-fps/alephone/alephone-9999.ebuild
+++ b/games-fps/alephone/alephone-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit autotools optfeature prefix xdg
+inherit autotools optfeature prefix toolchain-funcs xdg
DESCRIPTION="An enhanced version of the game engine from the classic Mac game, Marathon"
HOMEPAGE="http://source.bungie.org/"
@@ -75,6 +75,11 @@ src_configure() {
$(use_with upnp miniupnpc)
}
+src_compile() {
+ tc-export AR
+ default
+}
+
src_install() {
default
prefixify_ro "${FILESDIR}"/${PN}.sh