summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/mgba/mgba-0.6.3.ebuild')
-rw-r--r--games-emulation/mgba/mgba-0.6.3.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/games-emulation/mgba/mgba-0.6.3.ebuild b/games-emulation/mgba/mgba-0.6.3.ebuild
index b1c0a8b0b0ad..6674579a2fcc 100644
--- a/games-emulation/mgba/mgba-0.6.3.ebuild
+++ b/games-emulation/mgba/mgba-0.6.3.ebuild
@@ -12,7 +12,7 @@ SRC_URI="https://github.com/${PN}-emu/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MPL-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="debug ffmpeg imagemagick opengl qt5 +sdl"
+IUSE="debug ffmpeg imagemagick libav opengl qt5 +sdl"
REQUIRED_USE="|| ( qt5 sdl )
qt5? ( opengl )"
@@ -20,7 +20,10 @@ RDEPEND="
dev-db/sqlite:3
media-libs/libpng:0=
sys-libs/zlib[minizip]
- ffmpeg? ( virtual/ffmpeg )
+ ffmpeg? (
+ libav? ( media-video/libav:= )
+ !libav? ( media-video/ffmpeg:= )
+ )
imagemagick? ( media-gfx/imagemagick:= )
opengl? ( virtual/opengl )
qt5? (
@@ -45,8 +48,8 @@ src_prepare() {
src_configure() {
local mycmakeargs=(
+ -DCMAKE_SKIP_RPATH=ON
-DBUILD_GL="$(usex opengl)"
- -DBUILD_GLES=OFF
-DBUILD_PYTHON=OFF
-DBUILD_QT="$(usex qt5)"
-DBUILD_SDL="$(usex sdl)"