summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-board')
-rw-r--r--games-board/gnome-chess/Manifest1
-rw-r--r--games-board/gnome-chess/gnome-chess-3.30.1.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/games-board/gnome-chess/Manifest b/games-board/gnome-chess/Manifest
index 0539ec8ecc44..9fcfe48ceefb 100644
--- a/games-board/gnome-chess/Manifest
+++ b/games-board/gnome-chess/Manifest
@@ -1 +1,2 @@
DIST gnome-chess-3.28.1.tar.xz 1697524 BLAKE2B 743147e86fbaf5b1b1d84e802fde439de8a04f1e58607e34d0c5f660e59f3dd1e29aef1c763e5a00fa44581502c1d702a7fd9dfc826281f4dc703b23430a1efc SHA512 296703362fab5afa221130293d09a2f4e8d36d211f6fde7cee54c52a7ccec4c3a8aa5359baaf330e95cfd42277e2f95d44d762518a86d675c8e8a7237ebd9dd1
+DIST gnome-chess-3.30.1.tar.xz 1699668 BLAKE2B 5cb445248f3e223354f5145ee6e652b05d2ced44cbe63705fd54514d7848b5932b3aced35e3e6b72944f0e1e2c2b73ff8b9ad2b0c38fa0e90de5e59bf1da36e5 SHA512 ddf1b62b189adb01e9874606fa45b77b00bb5ca52609db60c58b6c0bca5340786f37a8ef813bb82213c8f7335117d2b896420826cae131db13e77d72e8ad5804
diff --git a/games-board/gnome-chess/gnome-chess-3.30.1.ebuild b/games-board/gnome-chess/gnome-chess-3.30.1.ebuild
new file mode 100644
index 000000000000..f52f27cab4f1
--- /dev/null
+++ b/games-board/gnome-chess/gnome-chess-3.30.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+VALA_MIN_API_VERSION="0.36"
+
+inherit gnome.org gnome2-utils meson readme.gentoo-r1 vala xdg
+
+DESCRIPTION="Play the classic two-player boardgame of chess"
+HOMEPAGE="https://wiki.gnome.org/Apps/Chess"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.44:2
+ >=x11-libs/gtk+-3.20.0:3
+ >=gnome-base/librsvg-2.32.0:2[vala]
+"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ dev-util/itstool
+ dev-libs/appstream-glib
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+DOC_CONTENTS="For being able to play against computer you will
+need to install a chess engine like, for example, games-board/gnuchess"
+
+src_prepare() {
+ xdg_src_prepare
+ vala_src_prepare
+}
+
+src_install() {
+ meson_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}