summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/meson/files/test-llvm.patch')
-rw-r--r--dev-util/meson/files/test-llvm.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-util/meson/files/test-llvm.patch b/dev-util/meson/files/test-llvm.patch
new file mode 100644
index 000000000000..af7b9834bf33
--- /dev/null
+++ b/dev-util/meson/files/test-llvm.patch
@@ -0,0 +1,26 @@
+From 40457b1faa2c5b274447838ff1a041a8030c6c22 Mon Sep 17 00:00:00 2001
+From: Mike Gilbert <floppym@gentoo.org>
+Date: Sat, 6 Oct 2018 21:11:36 -0400
+Subject: [PATCH] Disable testing of static llvm linkage
+
+Gentoo doesn't provide static libs for llvm.
+---
+ test cases/frameworks/15 llvm/meson.build | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/test cases/frameworks/15 llvm/meson.build b/test cases/frameworks/15 llvm/meson.build
+index e05fddd2..9b38a454 100644
+--- a/test cases/frameworks/15 llvm/meson.build
++++ b/test cases/frameworks/15 llvm/meson.build
+@@ -20,7 +20,7 @@ if not dep_tinfo.found()
+ dep_tinfo = cpp.find_library('tinfo', required: false)
+ endif
+
+-foreach static : [true, false]
++foreach static : [false]
+ llvm_dep = dependency(
+ 'llvm',
+ modules : ['bitwriter', 'asmprinter', 'executionengine', 'target',
+--
+2.19.0
+