summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/ply/ply-3.6-r1.ebuild8
-rw-r--r--dev-python/ply/ply-3.8.ebuild8
-rw-r--r--dev-python/ply/ply-3.9.ebuild6
3 files changed, 11 insertions, 11 deletions
diff --git a/dev-python/ply/ply-3.6-r1.ebuild b/dev-python/ply/ply-3.6-r1.ebuild
index b9c8333cada0..a3436a4ed3ad 100644
--- a/dev-python/ply/ply-3.6-r1.ebuild
+++ b/dev-python/ply/ply-3.6-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -19,9 +19,6 @@ IUSE="examples"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND=""
-# See bug #458648 for reference
-RESTRICT="test"
-
DOCS=( ANNOUNCE CHANGES TODO )
PATCHES=(
"${FILESDIR}/3.6-lextab-None.patch"
@@ -32,6 +29,9 @@ python_test() {
cp -r -l test "${BUILD_DIR}"/ || die
cd "${BUILD_DIR}"/test || die
+ # Checks for pyc/pyo files
+ local -x PYTHONDONTWRITEBYTECODE=
+
local t
for t in testlex.py testyacc.py; do
"${PYTHON}" "${t}" || die "${t} fails with ${EPYTHON}"
diff --git a/dev-python/ply/ply-3.8.ebuild b/dev-python/ply/ply-3.8.ebuild
index 9f368cb637be..35f8116dcf7e 100644
--- a/dev-python/ply/ply-3.8.ebuild
+++ b/dev-python/ply/ply-3.8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -20,9 +20,6 @@ IUSE="examples"
RDEPEND=""
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-# See bug #458648 for reference
-RESTRICT="test"
-
DOCS=( ANNOUNCE CHANGES TODO )
PATCHES=( "${FILESDIR}/3.6-picklefile-IOError.patch" )
@@ -31,6 +28,9 @@ python_test() {
cp -r -l test "${BUILD_DIR}"/ || die
cd "${BUILD_DIR}"/test || die
+ # Checks for pyc/pyo files
+ local -x PYTHONDONTWRITEBYTECODE=
+
local t
for t in testlex.py testyacc.py; do
"${PYTHON}" "${t}" || die "${t} fails with ${EPYTHON}"
diff --git a/dev-python/ply/ply-3.9.ebuild b/dev-python/ply/ply-3.9.ebuild
index 8c335d71358f..92d21999fdaf 100644
--- a/dev-python/ply/ply-3.9.ebuild
+++ b/dev-python/ply/ply-3.9.ebuild
@@ -20,9 +20,6 @@ IUSE="examples"
RDEPEND=""
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-# See bug #458648 for reference
-RESTRICT="test"
-
DOCS=( ANNOUNCE CHANGES TODO )
PATCHES=( "${FILESDIR}/3.6-picklefile-IOError.patch" )
@@ -31,6 +28,9 @@ python_test() {
cp -r -l test "${BUILD_DIR}"/ || die
cd "${BUILD_DIR}"/test || die
+ # Checks for pyc/pyo files
+ local -x PYTHONDONTWRITEBYTECODE=
+
local t
for t in testlex.py testyacc.py; do
"${PYTHON}" "${t}" || die "${t} fails with ${EPYTHON}"