summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pypy3')
-rw-r--r--dev-python/pypy3/pypy3-7.3.1-r1.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/pypy3/pypy3-7.3.1-r1.ebuild b/dev-python/pypy3/pypy3-7.3.1-r1.ebuild
index 693635092afb..023f8e46c876 100644
--- a/dev-python/pypy3/pypy3-7.3.1-r1.ebuild
+++ b/dev-python/pypy3/pypy3-7.3.1-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=7
PYTHON_COMPAT=( python2_7 )
-inherit pax-utils python-any-r1
+inherit pax-utils python-any-r1 toolchain-funcs
MY_P=pypy3.6-v${PV/_/}
@@ -105,6 +105,10 @@ src_prepare() {
eapply_user
}
+src_configure() {
+ tc-export CC
+}
+
src_compile() {
# copy over to make sys.prefix happy
cp -p "${BROOT}"/usr/lib/pypy3.6/pypy3-c-${PV} pypy3-c || die