summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/PEAR-Net_SMTP/PEAR-Net_SMTP-1.7.2-r2.ebuild')
-rw-r--r--dev-php/PEAR-Net_SMTP/PEAR-Net_SMTP-1.7.2-r2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-php/PEAR-Net_SMTP/PEAR-Net_SMTP-1.7.2-r2.ebuild b/dev-php/PEAR-Net_SMTP/PEAR-Net_SMTP-1.7.2-r2.ebuild
new file mode 100644
index 000000000000..1a95530e6ab1
--- /dev/null
+++ b/dev-php/PEAR-Net_SMTP/PEAR-Net_SMTP-1.7.2-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MY_PN="${PN/PEAR-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A PHP implementation of the SMTP protocol"
+HOMEPAGE="http://pear.php.net/package/${MY_PN}"
+SRC_URI="http://download.pear.php.net/package/${MY_P}.tgz"
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="examples sasl"
+DEPEND=""
+RDEPEND="dev-lang/php:*
+ dev-php/PEAR-Net_Socket
+ dev-php/pear
+ sasl? ( dev-php/PEAR-Auth_SASL )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ dodoc docs/guide.txt
+ use examples && dodoc -r examples
+
+ insinto /usr/share/php
+ doins -r Net
+}