summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Config-AutoConf/Config-AutoConf-0.320.0.ebuild4
-rw-r--r--dev-perl/File-Scan-ClamAV/File-Scan-ClamAV-1.950.0-r2.ebuild40
-rw-r--r--dev-perl/Search-Xapian/Search-Xapian-1.2.25.5-r1.ebuild38
-rw-r--r--dev-perl/Search-Xapian/Search-Xapian-1.2.25.5-r3.ebuild38
4 files changed, 2 insertions, 118 deletions
diff --git a/dev-perl/Config-AutoConf/Config-AutoConf-0.320.0.ebuild b/dev-perl/Config-AutoConf/Config-AutoConf-0.320.0.ebuild
index b89a0bba69b8..8f54eafb24d5 100644
--- a/dev-perl/Config-AutoConf/Config-AutoConf-0.320.0.ebuild
+++ b/dev-perl/Config-AutoConf/Config-AutoConf-0.320.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -11,7 +11,7 @@ inherit perl-module
DESCRIPTION="Module to implement some of AutoConf macros in pure perl"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
RDEPEND="
dev-perl/Capture-Tiny
diff --git a/dev-perl/File-Scan-ClamAV/File-Scan-ClamAV-1.950.0-r2.ebuild b/dev-perl/File-Scan-ClamAV/File-Scan-ClamAV-1.950.0-r2.ebuild
deleted file mode 100644
index 0ac7fefcdc81..000000000000
--- a/dev-perl/File-Scan-ClamAV/File-Scan-ClamAV-1.950.0-r2.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DIST_AUTHOR=ESAYM
-DIST_VERSION=1.95
-
-inherit perl-module
-
-DESCRIPTION="Connect to a local Clam Anti-Virus clamd service and send commands"
-
-SLOT="0"
-KEYWORDS="~amd64 ~sparc ~x86"
-
-RDEPEND="
- app-antivirus/clamav
-"
-BDEPEND="
- ${RDEPEND}
- virtual/perl-ExtUtils-MakeMaker
-"
-
-# Test's can't be run in parallel because they internally spawn a
-# clam server on the same shared socket
-DIST_TEST="do"
-
-src_test() {
- if [[ "${TEST_SCAN_CLAMAV:-0}" == "1" || -n "${DIST_TEST_OVERRIDE}" ]]; then
- perl_rm_files t/pod-coverage.t t/pod.t
- perl-module_src_test
- else
- einfo "Skipping Tests."
- einfo
- einfo "Tests require a manually and correctly configured ClamAV."
- einfo
- einfo "Set TEST_SCAN_CLAMAV=1 if you wish to run this test and have"
- einfo "configured ClamAV"
- fi
-}
diff --git a/dev-perl/Search-Xapian/Search-Xapian-1.2.25.5-r1.ebuild b/dev-perl/Search-Xapian/Search-Xapian-1.2.25.5-r1.ebuild
deleted file mode 100644
index 9d499a36a930..000000000000
--- a/dev-perl/Search-Xapian/Search-Xapian-1.2.25.5-r1.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DIST_AUTHOR=OLLY
-inherit perl-module toolchain-funcs
-
-DESCRIPTION="Perl XS frontend to the Xapian C++ search library"
-
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~mips ppc ppc64 ~sparc x86"
-IUSE="examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=">=dev-libs/xapian-1.4:0=
- !dev-libs/xapian-bindings[perl]"
-DEPEND="${RDEPEND}
- virtual/perl-ExtUtils-MakeMaker
- test? ( dev-perl/Devel-Leak )
-"
-
-DIST_TEST=do
-# parallel fails sometimes...
-
-src_configure() {
- myconf="CXX=$(tc-getCXX) CXXFLAGS=${CXXFLAGS}"
- perl-module_src_configure
-}
-
-src_install() {
- perl-module_src_install
-
- use examples && {
- docinto examples
- dodoc "${S}"/examples/*
- }
-}
diff --git a/dev-perl/Search-Xapian/Search-Xapian-1.2.25.5-r3.ebuild b/dev-perl/Search-Xapian/Search-Xapian-1.2.25.5-r3.ebuild
deleted file mode 100644
index 3c4566a26520..000000000000
--- a/dev-perl/Search-Xapian/Search-Xapian-1.2.25.5-r3.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DIST_AUTHOR=OLLY
-inherit perl-module toolchain-funcs
-
-DESCRIPTION="Perl XS frontend to the Xapian C++ search library"
-
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~mips ~ppc ~ppc64 ~sparc ~x86"
-IUSE="examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=">=dev-libs/xapian-1.4:0=[inmemory(+)]
- !dev-libs/xapian-bindings[perl]"
-DEPEND="${RDEPEND}
- virtual/perl-ExtUtils-MakeMaker
- test? ( dev-perl/Devel-Leak )
-"
-
-DIST_TEST=do
-# parallel fails sometimes...
-
-src_configure() {
- myconf="CXX=$(tc-getCXX) CXXFLAGS=${CXXFLAGS}"
- perl-module_src_configure
-}
-
-src_install() {
- perl-module_src_install
-
- use examples && {
- docinto examples
- dodoc "${S}"/examples/*
- }
-}