summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/llvm-ocaml/llvm-ocaml-4.0.1.ebuild12
-rw-r--r--dev-ml/llvm-ocaml/llvm-ocaml-5.0.9999.ebuild12
-rw-r--r--dev-ml/llvm-ocaml/llvm-ocaml-9999.ebuild9
3 files changed, 3 insertions, 30 deletions
diff --git a/dev-ml/llvm-ocaml/llvm-ocaml-4.0.1.ebuild b/dev-ml/llvm-ocaml/llvm-ocaml-4.0.1.ebuild
index 6375c108d859..5eda59e817ee 100644
--- a/dev-ml/llvm-ocaml/llvm-ocaml-4.0.1.ebuild
+++ b/dev-ml/llvm-ocaml/llvm-ocaml-4.0.1.ebuild
@@ -35,8 +35,7 @@ RDEPEND="
DEPEND="${RDEPEND}
dev-lang/perl
dev-ml/findlib
- test? ( dev-ml/ounit
- $(python_gen_any_dep "~dev-python/lit-${PV}[\${PYTHON_USEDEP}]") )
+ test? ( dev-ml/ounit )
!!<dev-python/configparser-3.3.0.2
${PYTHON_DEPS}"
@@ -48,11 +47,6 @@ S=${WORKDIR}/${MY_P/_/}.src
# least intrusive of all
CMAKE_BUILD_TYPE=RelWithDebInfo
-python_check_deps() {
- ! use test \
- || has_version "dev-python/lit[${PYTHON_USEDEP}]"
-}
-
pkg_setup() {
LLVM_MAX_SLOT=${PV%%.*} llvm_pkg_setup
python-any-r1_pkg_setup
@@ -92,10 +86,6 @@ src_configure() {
# TODO: ocamldoc
)
- use test && mycmakeargs+=(
- -DLIT_COMMAND="${EPREFIX}/usr/bin/lit"
- )
-
cmake-utils_src_configure
local llvm_libdir=$(llvm-config --libdir)
diff --git a/dev-ml/llvm-ocaml/llvm-ocaml-5.0.9999.ebuild b/dev-ml/llvm-ocaml/llvm-ocaml-5.0.9999.ebuild
index 0c2ad271f5c3..b7e7d9839de6 100644
--- a/dev-ml/llvm-ocaml/llvm-ocaml-5.0.9999.ebuild
+++ b/dev-ml/llvm-ocaml/llvm-ocaml-5.0.9999.ebuild
@@ -37,8 +37,7 @@ RDEPEND="
DEPEND="${RDEPEND}
dev-lang/perl
dev-ml/findlib
- test? ( dev-ml/ounit
- $(python_gen_any_dep "~dev-python/lit-${PV}[\${PYTHON_USEDEP}]") )
+ test? ( dev-ml/ounit )
!!<dev-python/configparser-3.3.0.2
${PYTHON_DEPS}"
@@ -48,11 +47,6 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}
# least intrusive of all
CMAKE_BUILD_TYPE=RelWithDebInfo
-python_check_deps() {
- ! use test \
- || has_version "dev-python/lit[${PYTHON_USEDEP}]"
-}
-
pkg_setup() {
LLVM_MAX_SLOT=${PV%%.*} llvm_pkg_setup
python-any-r1_pkg_setup
@@ -92,10 +86,6 @@ src_configure() {
# TODO: ocamldoc
)
- use test && mycmakeargs+=(
- -DLIT_COMMAND="${EPREFIX}/usr/bin/lit"
- )
-
# LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
# also: custom rules for OCaml do not work for CPPFLAGS
use debug || local -x CFLAGS="${CFLAGS} -DNDEBUG"
diff --git a/dev-ml/llvm-ocaml/llvm-ocaml-9999.ebuild b/dev-ml/llvm-ocaml/llvm-ocaml-9999.ebuild
index 7bb17679f8d1..2fa7019d717d 100644
--- a/dev-ml/llvm-ocaml/llvm-ocaml-9999.ebuild
+++ b/dev-ml/llvm-ocaml/llvm-ocaml-9999.ebuild
@@ -38,8 +38,7 @@ RDEPEND="
DEPEND="${RDEPEND}
dev-lang/perl
dev-ml/findlib
- test? ( dev-ml/ounit
- $(python_gen_any_dep "~dev-python/lit-${PV}[\${PYTHON_USEDEP}]") )
+ test? ( dev-ml/ounit )
!!<dev-python/configparser-3.3.0.2
${PYTHON_DEPS}"
@@ -49,11 +48,6 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}
# least intrusive of all
CMAKE_BUILD_TYPE=RelWithDebInfo
-python_check_deps() {
- ! use test \
- || has_version "dev-python/lit[${PYTHON_USEDEP}]"
-}
-
pkg_setup() {
llvm_pkg_setup
python-any-r1_pkg_setup
@@ -97,7 +91,6 @@ src_configure() {
)
use test && mycmakeargs+=(
- -DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"
-DLLVM_LIT_ARGS="-vv"
)