summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/optparse-applicative/optparse-applicative-0.8.1-r1.ebuild')
-rw-r--r--dev-haskell/optparse-applicative/optparse-applicative-0.8.1-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-haskell/optparse-applicative/optparse-applicative-0.8.1-r1.ebuild b/dev-haskell/optparse-applicative/optparse-applicative-0.8.1-r1.ebuild
new file mode 100644
index 000000000000..375c6191c06f
--- /dev/null
+++ b/dev-haskell/optparse-applicative/optparse-applicative-0.8.1-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Utilities and combinators for parsing command line options"
+HOMEPAGE="https://github.com/pcapriotti/optparse-applicative"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/ansi-wl-pprint-0.6:=[profile?] <dev-haskell/ansi-wl-pprint-0.7:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?] <dev-haskell/transformers-0.5:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/hunit-1.2 <dev-haskell/hunit-1.3
+ >=dev-haskell/quickcheck-2.6 <dev-haskell/quickcheck-2.8
+ >=dev-haskell/test-framework-0.6 <dev-haskell/test-framework-0.9
+ >=dev-haskell/test-framework-hunit-0.2 <dev-haskell/test-framework-hunit-0.4
+ >=dev-haskell/test-framework-quickcheck2-0.3 <dev-haskell/test-framework-quickcheck2-0.4
+ >=dev-haskell/test-framework-th-prime-0.0 <dev-haskell/test-framework-th-prime-0.1 )
+"
+
+src_prepare() {
+ cabal_chdeps \
+ 'transformers >= 0.2 && < 0.4' \
+ 'transformers >= 0.2 && < 0.5'
+}