summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/aeson/aeson-0.7.0.6.ebuild')
-rw-r--r--dev-haskell/aeson/aeson-0.7.0.6.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-haskell/aeson/aeson-0.7.0.6.ebuild b/dev-haskell/aeson/aeson-0.7.0.6.ebuild
new file mode 100644
index 000000000000..a7ca13231fb7
--- /dev/null
+++ b/dev-haskell/aeson/aeson-0.7.0.6.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Fast JSON parsing and encoding"
+HOMEPAGE="https://github.com/bos/aeson"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="developer"
+
+RDEPEND=">=dev-haskell/attoparsec-0.11.3.4:=[profile?]
+ >=dev-haskell/blaze-builder-0.2.1.4:=[profile?]
+ >=dev-haskell/dlist-0.2:=[profile?]
+ >=dev-haskell/hashable-1.1.2.0:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/scientific-0.3.1:=[bytestring-builder,profile?] <dev-haskell/scientific-0.4:=[bytestring-builder,profile?]
+ dev-haskell/syb:=[profile?]
+ >=dev-haskell/text-0.11.1.0:=[profile?]
+ >=dev-haskell/unordered-containers-0.2.3.0:=[profile?]
+ >=dev-haskell/vector-0.7.1:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/attoparsec
+ dev-haskell/hunit
+ dev-haskell/quickcheck
+ dev-haskell/test-framework
+ dev-haskell/test-framework-hunit
+ dev-haskell/test-framework-quickcheck2
+ dev-haskell/text
+ dev-haskell/unordered-containers
+ dev-haskell/vector )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag developer developer)
+}