summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/sqlite')
-rw-r--r--dev-db/sqlite/sqlite-3.34.1.ebuild6
-rw-r--r--dev-db/sqlite/sqlite-3.35.0.ebuild6
-rw-r--r--dev-db/sqlite/sqlite-3.35.1.ebuild6
-rw-r--r--dev-db/sqlite/sqlite-3.35.2.ebuild6
-rw-r--r--dev-db/sqlite/sqlite-3.35.3.ebuild6
-rw-r--r--dev-db/sqlite/sqlite-3.35.4.ebuild6
-rw-r--r--dev-db/sqlite/sqlite-3.35.5.ebuild6
7 files changed, 0 insertions, 42 deletions
diff --git a/dev-db/sqlite/sqlite-3.34.1.ebuild b/dev-db/sqlite/sqlite-3.34.1.ebuild
index 623578707fa3..6c812d3550d0 100644
--- a/dev-db/sqlite/sqlite-3.34.1.ebuild
+++ b/dev-db/sqlite/sqlite-3.34.1.ebuild
@@ -320,12 +320,6 @@ multilib_src_configure() {
options+=(--disable-tcl)
fi
- if [[ "${CHOST}" == *-mint* ]]; then
- # sys/mman.h not available in MiNTLib.
- # https://sqlite.org/compile.html#omit_wal
- append-cppflags -DSQLITE_OMIT_WAL
- fi
-
if [[ "${ABI}" == "x86" ]]; then
if $(tc-getCC) ${CPPFLAGS} ${CFLAGS} -E -P -dM - < /dev/null 2> /dev/null | grep -q "^#define __SSE__ 1$"; then
append-cflags -mfpmath=sse
diff --git a/dev-db/sqlite/sqlite-3.35.0.ebuild b/dev-db/sqlite/sqlite-3.35.0.ebuild
index e1762793c342..c55b60d754d1 100644
--- a/dev-db/sqlite/sqlite-3.35.0.ebuild
+++ b/dev-db/sqlite/sqlite-3.35.0.ebuild
@@ -320,12 +320,6 @@ multilib_src_configure() {
options+=(--disable-tcl)
fi
- if [[ "${CHOST}" == *-mint* ]]; then
- # sys/mman.h not available in MiNTLib.
- # https://sqlite.org/compile.html#omit_wal
- append-cppflags -DSQLITE_OMIT_WAL
- fi
-
if [[ "${ABI}" == "x86" ]]; then
if $(tc-getCC) ${CPPFLAGS} ${CFLAGS} -E -P -dM - < /dev/null 2> /dev/null | grep -q "^#define __SSE__ 1$"; then
append-cflags -mfpmath=sse
diff --git a/dev-db/sqlite/sqlite-3.35.1.ebuild b/dev-db/sqlite/sqlite-3.35.1.ebuild
index e1762793c342..c55b60d754d1 100644
--- a/dev-db/sqlite/sqlite-3.35.1.ebuild
+++ b/dev-db/sqlite/sqlite-3.35.1.ebuild
@@ -320,12 +320,6 @@ multilib_src_configure() {
options+=(--disable-tcl)
fi
- if [[ "${CHOST}" == *-mint* ]]; then
- # sys/mman.h not available in MiNTLib.
- # https://sqlite.org/compile.html#omit_wal
- append-cppflags -DSQLITE_OMIT_WAL
- fi
-
if [[ "${ABI}" == "x86" ]]; then
if $(tc-getCC) ${CPPFLAGS} ${CFLAGS} -E -P -dM - < /dev/null 2> /dev/null | grep -q "^#define __SSE__ 1$"; then
append-cflags -mfpmath=sse
diff --git a/dev-db/sqlite/sqlite-3.35.2.ebuild b/dev-db/sqlite/sqlite-3.35.2.ebuild
index e1762793c342..c55b60d754d1 100644
--- a/dev-db/sqlite/sqlite-3.35.2.ebuild
+++ b/dev-db/sqlite/sqlite-3.35.2.ebuild
@@ -320,12 +320,6 @@ multilib_src_configure() {
options+=(--disable-tcl)
fi
- if [[ "${CHOST}" == *-mint* ]]; then
- # sys/mman.h not available in MiNTLib.
- # https://sqlite.org/compile.html#omit_wal
- append-cppflags -DSQLITE_OMIT_WAL
- fi
-
if [[ "${ABI}" == "x86" ]]; then
if $(tc-getCC) ${CPPFLAGS} ${CFLAGS} -E -P -dM - < /dev/null 2> /dev/null | grep -q "^#define __SSE__ 1$"; then
append-cflags -mfpmath=sse
diff --git a/dev-db/sqlite/sqlite-3.35.3.ebuild b/dev-db/sqlite/sqlite-3.35.3.ebuild
index e1762793c342..c55b60d754d1 100644
--- a/dev-db/sqlite/sqlite-3.35.3.ebuild
+++ b/dev-db/sqlite/sqlite-3.35.3.ebuild
@@ -320,12 +320,6 @@ multilib_src_configure() {
options+=(--disable-tcl)
fi
- if [[ "${CHOST}" == *-mint* ]]; then
- # sys/mman.h not available in MiNTLib.
- # https://sqlite.org/compile.html#omit_wal
- append-cppflags -DSQLITE_OMIT_WAL
- fi
-
if [[ "${ABI}" == "x86" ]]; then
if $(tc-getCC) ${CPPFLAGS} ${CFLAGS} -E -P -dM - < /dev/null 2> /dev/null | grep -q "^#define __SSE__ 1$"; then
append-cflags -mfpmath=sse
diff --git a/dev-db/sqlite/sqlite-3.35.4.ebuild b/dev-db/sqlite/sqlite-3.35.4.ebuild
index e1762793c342..c55b60d754d1 100644
--- a/dev-db/sqlite/sqlite-3.35.4.ebuild
+++ b/dev-db/sqlite/sqlite-3.35.4.ebuild
@@ -320,12 +320,6 @@ multilib_src_configure() {
options+=(--disable-tcl)
fi
- if [[ "${CHOST}" == *-mint* ]]; then
- # sys/mman.h not available in MiNTLib.
- # https://sqlite.org/compile.html#omit_wal
- append-cppflags -DSQLITE_OMIT_WAL
- fi
-
if [[ "${ABI}" == "x86" ]]; then
if $(tc-getCC) ${CPPFLAGS} ${CFLAGS} -E -P -dM - < /dev/null 2> /dev/null | grep -q "^#define __SSE__ 1$"; then
append-cflags -mfpmath=sse
diff --git a/dev-db/sqlite/sqlite-3.35.5.ebuild b/dev-db/sqlite/sqlite-3.35.5.ebuild
index e1762793c342..c55b60d754d1 100644
--- a/dev-db/sqlite/sqlite-3.35.5.ebuild
+++ b/dev-db/sqlite/sqlite-3.35.5.ebuild
@@ -320,12 +320,6 @@ multilib_src_configure() {
options+=(--disable-tcl)
fi
- if [[ "${CHOST}" == *-mint* ]]; then
- # sys/mman.h not available in MiNTLib.
- # https://sqlite.org/compile.html#omit_wal
- append-cppflags -DSQLITE_OMIT_WAL
- fi
-
if [[ "${ABI}" == "x86" ]]; then
if $(tc-getCC) ${CPPFLAGS} ${CFLAGS} -E -P -dM - < /dev/null 2> /dev/null | grep -q "^#define __SSE__ 1$"; then
append-cflags -mfpmath=sse