summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/xindy/xindy-2.4.ebuild')
-rw-r--r--app-text/xindy/xindy-2.4.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-text/xindy/xindy-2.4.ebuild b/app-text/xindy/xindy-2.4.ebuild
new file mode 100644
index 000000000000..11ebfb72ef9b
--- /dev/null
+++ b/app-text/xindy/xindy-2.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+inherit eutils autotools
+
+DESCRIPTION="A Flexible Indexing System"
+HOMEPAGE="http://www.xindy.org/"
+SRC_URI="http://www.xindy.org/xindy-2.4.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ppc x86"
+IUSE="doc"
+
+RDEPEND="virtual/latex-base
+ >=dev-lisp/clisp-2.44.1-r1
+ dev-texlive/texlive-langcyrillic"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ sys-devel/flex"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-configure.patch
+ epatch "${FILESDIR}"/${P}-locale.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable doc docs)
+}
+
+src_compile() {
+ VARTEXFONTS="${T}/fonts" emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog.Gour NEWS README
+}