summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/texi2html')
-rw-r--r--app-text/texi2html/Manifest1
-rw-r--r--app-text/texi2html/metadata.xml5
-rw-r--r--app-text/texi2html/texi2html-5.0-r1.ebuild51
3 files changed, 57 insertions, 0 deletions
diff --git a/app-text/texi2html/Manifest b/app-text/texi2html/Manifest
new file mode 100644
index 000000000000..89b472343236
--- /dev/null
+++ b/app-text/texi2html/Manifest
@@ -0,0 +1 @@
+DIST texi2html-5.0.tar.bz2 15397249 SHA256 e8a98b0ee20c495a6ab894398a065ef580272dbd5a15b1b19e8bd1bc89d9f9fa SHA512 50afc2f1f8875d3e62a51cc0339bd4c4f058041f42a9fda9cd5b02960f0d5c72838e4f010702ba716dbd256946f64520ce1e5b86539b6f7b8b7ce24a43c98e9d WHIRLPOOL d881c31767c5dd26c283910a570ab880fb10f5d11549682056da7a61a22b1a1aa12a9f17a6695124516f57b8952104d9f127e69268f529ed547c2dedc32569be
diff --git a/app-text/texi2html/metadata.xml b/app-text/texi2html/metadata.xml
new file mode 100644
index 000000000000..ba6a8a8800d5
--- /dev/null
+++ b/app-text/texi2html/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>tex</herd>
+</pkgmetadata>
diff --git a/app-text/texi2html/texi2html-5.0-r1.ebuild b/app-text/texi2html/texi2html-5.0-r1.ebuild
new file mode 100644
index 000000000000..ed0668c0bc71
--- /dev/null
+++ b/app-text/texi2html/texi2html-5.0-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="Perl script that converts Texinfo to HTML"
+HOMEPAGE="http://www.nongnu.org/texi2html/"
+SRC_URI="mirror://nongnu/${PN}/${P}.tar.bz2"
+
+LICENSE="CC-SA-1.0 FDL-1.3 GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="unicode"
+
+RDEPEND=">=dev-lang/perl-5.10.1
+ >=dev-perl/libintl-perl-1.200
+ unicode? (
+ dev-perl/Text-Unidecode
+ dev-perl/Unicode-EastAsianWidth
+ )"
+DEPEND="${RDEPEND}"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+RESTRICT="test" #411523
+
+src_prepare() {
+ # On FreeBSD this script is used instead of GNU install but it comes without
+ # executable pemissions... Fix it!
+ chmod +x install-sh || die
+}
+
+src_configure() {
+ local myconf
+ use unicode && myconf='--with-external-Unicode-EastAsianWidth'
+
+ econf \
+ --with-external-libintl-perl \
+ $(use_with unicode unidecode) \
+ ${myconf}
+}
+
+src_install() {
+ default
+ rm -f "${ED}"/usr/share/${PN}/images/{COPYING*,GPL,README}
+}
+
+pkg_preinst() {
+ rm -f "${EROOT}"/usr/bin/${PN}
+}