summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/epspdf')
-rw-r--r--app-text/epspdf/Manifest3
-rw-r--r--app-text/epspdf/epspdf-0.5.3.ebuild55
-rw-r--r--app-text/epspdf/epspdf-0.6.0.ebuild49
-rw-r--r--app-text/epspdf/epspdf-0.6.1.ebuild54
-rw-r--r--app-text/epspdf/metadata.xml5
5 files changed, 166 insertions, 0 deletions
diff --git a/app-text/epspdf/Manifest b/app-text/epspdf/Manifest
new file mode 100644
index 000000000000..eaa906f56e92
--- /dev/null
+++ b/app-text/epspdf/Manifest
@@ -0,0 +1,3 @@
+DIST epspdf.0.5.3.tgz 436341 SHA256 71ecbaf5e7fc1e525e865fa98b2f64d64f3c084eafdfee8e3a23203a9c191eba SHA512 fa2a777c0036ba5b1b960064c13ec1dd8f9180258e4f92fd46a5703c90214b154c7e231faada29f6d0da3b02062e8262b20a8a535ccfc702032bf1c07d4131e2 WHIRLPOOL 46e36bdf55925584a66ab00f807a4fcd52df7ae5913aa58be2889a8c7d07bddd00f6c8de54c19b00a9f30063b3ba1dac6e267bb02223d7410d4d29d1a70c6110
+DIST epspdf.0.6.0.tgz 352989 SHA256 8cceb04f011d1583b7257c1d54c491701ccb76c8d7560923f5b24cb5f264b5f5 SHA512 44a7015fa0b7298429567e998068864419fd396f6b0781bf7877c6599d3bb2f254b7a0f976500655851a95d727880d106d9e1df9086306eef74db0b109a63506 WHIRLPOOL f47bb164d4ffb203cb2931921ba8bc04232568560882f1f3c7a5fb51db41e44f26b9c58178cdace2e1d608b3a79fd692ca15c0ca344008992b7109c973a98e49
+DIST epspdf.0.6.1.tgz 343913 SHA256 8452f9b4a547cc6aac9170aa1eea88ce903e07d31e4cc645b1fb76e7555db3f0 SHA512 3efa037e9081d4c4c74ba56e2c7767c8abafb64e5f0a9f73fcf6b1e6ca7e6f68576555aff4031b8cd82ebdf001949a4455648dad3bf79ee6a37be1c73a5b4443 WHIRLPOOL 3c3a40d80df5b172d2065b983ed535ca4f6b5a96f0410bbe2319aff3fe7c217fafffad7d7f60778ca5d544daa7c56c6a8afbdf458dfce8dccde89bb0f42a1821
diff --git a/app-text/epspdf/epspdf-0.5.3.ebuild b/app-text/epspdf/epspdf-0.5.3.ebuild
new file mode 100644
index 000000000000..0e83588f4233
--- /dev/null
+++ b/app-text/epspdf/epspdf-0.5.3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit texlive-common eutils
+
+DESCRIPTION="GUI and command-line converter for [e]ps and pdf"
+HOMEPAGE="http://tex.aanhet.net/epspdf/"
+SRC_URI="http://tex.aanhet.net/epspdf/${PN}.${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc tk"
+
+DEPEND="sys-apps/texinfo"
+RDEPEND="!<dev-texlive/texlive-pictures-2011-r1
+ dev-lang/ruby
+ app-text/ghostscript-gpl
+ tk? ( dev-lang/tk )"
+
+S=${WORKDIR}/${PN}
+INSTALLDIR=/usr/share/${PN}
+FILES="epspdf.rb epspdfrc.rb makegray.pro"
+TKFILES="epspdf.help epspdf.icns epspdf.ico epspdftk.tcl"
+
+#epspdf.info seems broken, rebuild it
+src_compile() {
+ cd "${S}/doc"
+ makeinfo epspdf.texi || die
+}
+
+src_install() {
+ dodir ${INSTALLDIR}
+ cp -p ${FILES} "${ED}/${INSTALLDIR}" || die
+ if use tk ; then
+ cp -p ${TKFILES} "${ED}/${INSTALLDIR}" || die
+ fi
+ dobin_texmf_scripts "${PN}/epspdf.rb"
+ use tk && dobin_texmf_scripts "${PN}/epspdftk.tcl"
+
+ doinfo doc/epspdf.info
+ dodoc doc/Changelog
+ if use doc ; then
+ dodoc doc/epspdf.pdf
+ dohtml -r doc
+ fi
+
+ # give it a .desktop
+ if use tk; then
+ make_desktop_entry epspdftk epspdftk "${INSTALLDIR}/epspdf.ico" "Graphics;ImageProcessing"
+ fi
+}
diff --git a/app-text/epspdf/epspdf-0.6.0.ebuild b/app-text/epspdf/epspdf-0.6.0.ebuild
new file mode 100644
index 000000000000..513b7b3b18c4
--- /dev/null
+++ b/app-text/epspdf/epspdf-0.6.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit texlive-common eutils
+
+DESCRIPTION="GUI and command-line converter for [e]ps and pdf"
+HOMEPAGE="http://tex.aanhet.net/epspdf/"
+SRC_URI="http://tex.aanhet.net/epspdf/${PN}.${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc tk"
+
+DEPEND=""
+RDEPEND="!<dev-texlive/texlive-pictures-2011-r1
+ >=dev-texlive/texlive-basic-2011
+ app-text/ghostscript-gpl
+ tk? ( dev-lang/tk )"
+
+S=${WORKDIR}/${PN}
+INSTALLDIR=/usr/share/${PN}
+FILES="epspdf.tlu"
+TKFILES="epspdf.help epspdf.ico epspdftk.tcl"
+
+src_install() {
+ dodir ${INSTALLDIR}
+ cp -p ${FILES} "${ED}/${INSTALLDIR}" || die
+ if use tk ; then
+ cp -p ${TKFILES} "${ED}/${INSTALLDIR}" || die
+ fi
+ dobin_texmf_scripts "${PN}/epspdf.tlu"
+ use tk && dobin_texmf_scripts "${PN}/epspdftk.tcl"
+
+ doinfo doc/epspdf.info
+ dodoc doc/Changelog
+ if use doc ; then
+ dodoc doc/epspdf.pdf
+ dohtml -r doc
+ fi
+
+ # give it a .desktop
+ if use tk; then
+ make_desktop_entry epspdftk epspdftk "${INSTALLDIR}/epspdf.ico" "Graphics;ImageProcessing"
+ fi
+}
diff --git a/app-text/epspdf/epspdf-0.6.1.ebuild b/app-text/epspdf/epspdf-0.6.1.ebuild
new file mode 100644
index 000000000000..8d80bcdbdcc3
--- /dev/null
+++ b/app-text/epspdf/epspdf-0.6.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit texlive-common eutils
+
+DESCRIPTION="GUI and command-line converter for [e]ps and pdf"
+HOMEPAGE="http://tex.aanhet.net/epspdf/"
+SRC_URI="http://tex.aanhet.net/epspdf/${PN}.${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc tk"
+
+DEPEND="sys-apps/texinfo"
+RDEPEND="!<dev-texlive/texlive-pictures-2011-r1
+ >=dev-texlive/texlive-basic-2011
+ app-text/ghostscript-gpl
+ tk? ( dev-lang/tk )"
+
+S=${WORKDIR}/${PN}
+INSTALLDIR=/usr/share/${PN}
+FILES="epspdf.tlu"
+TKFILES="epspdf.help doc/images/epspdf.png epspdftk.tcl"
+
+src_compile() {
+ cd doc
+ makeinfo epspdf || die
+}
+
+src_install() {
+ dodir ${INSTALLDIR}
+ cp -p ${FILES} "${ED}/${INSTALLDIR}" || die
+ if use tk ; then
+ cp -p ${TKFILES} "${ED}/${INSTALLDIR}" || die
+ fi
+ dobin_texmf_scripts "${PN}/epspdf.tlu"
+ use tk && dobin_texmf_scripts "${PN}/epspdftk.tcl"
+
+ doinfo doc/epspdf.info
+ dodoc doc/Changelog
+ if use doc ; then
+ dodoc doc/epspdf.pdf
+ dohtml -r doc
+ fi
+
+ # give it a .desktop
+ if use tk; then
+ make_desktop_entry epspdftk epspdftk "${INSTALLDIR}/epspdf.png" "Graphics;ImageProcessing"
+ fi
+}
diff --git a/app-text/epspdf/metadata.xml b/app-text/epspdf/metadata.xml
new file mode 100644
index 000000000000..ba6a8a8800d5
--- /dev/null
+++ b/app-text/epspdf/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>tex</herd>
+</pkgmetadata>