summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/c2ps')
-rw-r--r--app-text/c2ps/Manifest1
-rw-r--r--app-text/c2ps/c2ps-4.0.ebuild27
-rw-r--r--app-text/c2ps/files/c2ps-4.0-LDFLAGS.patch11
-rw-r--r--app-text/c2ps/metadata.xml5
4 files changed, 44 insertions, 0 deletions
diff --git a/app-text/c2ps/Manifest b/app-text/c2ps/Manifest
new file mode 100644
index 000000000000..f6539e3559f9
--- /dev/null
+++ b/app-text/c2ps/Manifest
@@ -0,0 +1 @@
+DIST c2ps-4.0.tar.gz 48137 SHA256 c22800552b6018a7f01978cf918ad11ec780404b3fa87888e76929a08414a860 SHA512 dde931a201950412c8aad04a59f9ca0862b21a221bb7212ee64cbba0193421f1538804525361075be3ed601c5015a0c4e0c3592696f8b545f5a45524b2c5c619 WHIRLPOOL cefaa75a7553020059b05b0dca0b592a8b18632bb88f7b5b6caa7d22f24c8af95f4e30d0610ba1589b684b4904c7deca6339d5f0e2380bf29f25db9566d9f4b7
diff --git a/app-text/c2ps/c2ps-4.0.ebuild b/app-text/c2ps/c2ps-4.0.ebuild
new file mode 100644
index 000000000000..324e8e6e20fd
--- /dev/null
+++ b/app-text/c2ps/c2ps-4.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit base toolchain-funcs
+
+DESCRIPTION="Generates a beautified ps document from a source file (c/c++)"
+HOMEPAGE="http://www.cs.technion.ac.il/users/c2ps"
+SRC_URI="http://www.cs.technion.ac.il/users/c2ps/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~mips ppc sparc x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+PATCHES=( "${FILESDIR}/${P}-LDFLAGS.patch" )
+
+src_compile() {
+ emake CC="$(tc-getCC)" CCFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dodir /usr/bin /usr/share/man/man1
+ emake MAN="${ED}"/usr/share/man/man1 PREFIX="${ED}"/usr install
+ dodoc README
+}
diff --git a/app-text/c2ps/files/c2ps-4.0-LDFLAGS.patch b/app-text/c2ps/files/c2ps-4.0-LDFLAGS.patch
new file mode 100644
index 000000000000..d68002180091
--- /dev/null
+++ b/app-text/c2ps/files/c2ps-4.0-LDFLAGS.patch
@@ -0,0 +1,11 @@
+--- a/c2ps-4.0/Makefile 1997-05-15 11:50:56.000000000 -0400
++++ b/c2ps-4.0/Makefile 2010-09-24 19:42:33.000000000 -0400
+@@ -45,7 +45,7 @@
+ install -m 644 c2ps.1 $(MAN)
+
+ compile: c2ps.c
+- $(CC) $(PREP_OPTIONS) $(CCFLAGS) -o c2ps c2ps.c
++ $(CC) $(LDFLAGS) $(PREP_OPTIONS) $(CCFLAGS) -o c2ps c2ps.c $(LIBS)
+
+ clean:
+ $(RM) c2ps *.o core *~
diff --git a/app-text/c2ps/metadata.xml b/app-text/c2ps/metadata.xml
new file mode 100644
index 000000000000..1fa0ca569505
--- /dev/null
+++ b/app-text/c2ps/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>printing</herd>
+</pkgmetadata>