summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/an/an-1.2.ebuild')
-rw-r--r--app-text/an/an-1.2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-text/an/an-1.2.ebuild b/app-text/an/an-1.2.ebuild
new file mode 100644
index 000000000000..5846a7778995
--- /dev/null
+++ b/app-text/an/an-1.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Very fast anagram generator with dictionary lookup"
+HOMEPAGE="http://packages.debian.org/unstable/games/an"
+
+SRC_URI="mirror://debian/pool/main/a/${PN}/${PN}_${PV}.orig.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 hppa ppc ppc64 x86"
+IUSE=""
+
+CDEPEND="
+ dev-libs/icu:=
+"
+DEPEND="
+ app-arch/xz-utils
+"
+RDEPEND="
+ ${CDEPEND}
+ sys-apps/miscfiles[-minimal]
+"
+
+src_prepare() {
+ sed -i \
+ -e '/^CC/s|:=|?=|' \
+ -e 's|$(CC) $(CFLAGS)|& $(LDFLAGS)|g' \
+ Makefile || die
+ tc-export CC
+}
+
+src_install() {
+ dobin ${PN}
+ newman ${PN}.6 ${PN}.1
+ dodoc ALGORITHM
+}