summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/editor-wrapper')
-rw-r--r--app-misc/editor-wrapper/editor-wrapper-4.ebuild32
-rw-r--r--app-misc/editor-wrapper/files/editor-wrapper-4.sh17
-rw-r--r--app-misc/editor-wrapper/metadata.xml6
3 files changed, 55 insertions, 0 deletions
diff --git a/app-misc/editor-wrapper/editor-wrapper-4.ebuild b/app-misc/editor-wrapper/editor-wrapper-4.ebuild
new file mode 100644
index 000000000000..4ec011e0c83f
--- /dev/null
+++ b/app-misc/editor-wrapper/editor-wrapper-4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="Wrapper scripts that will execute EDITOR or PAGER"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI=""
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+S="${WORKDIR}"
+
+src_prepare() {
+ sed -e 's/@VAR@/EDITOR/g' "${FILESDIR}/${P}.sh" >editor || die
+ sed -e 's/@VAR@/PAGER/g' "${FILESDIR}/${P}.sh" >pager || die
+ if use prefix ; then
+ sed -i \
+ -e "s:#!/bin/sh:#!/usr/bin/env sh:" \
+ -e "s: /etc/profile: \"${EPREFIX}/etc/profile\":" \
+ editor pager || die
+ fi
+}
+
+src_install() {
+ exeinto /usr/libexec
+ doexe editor pager
+}
diff --git a/app-misc/editor-wrapper/files/editor-wrapper-4.sh b/app-misc/editor-wrapper/files/editor-wrapper-4.sh
new file mode 100644
index 000000000000..b58f1a8b9eeb
--- /dev/null
+++ b/app-misc/editor-wrapper/files/editor-wrapper-4.sh
@@ -0,0 +1,17 @@
+#!/bin/sh
+# Copyright 2009-2011 Gentoo Foundation
+# Distributed under the terms of the MIT/X11 license
+
+# Wrapper script, executes ${@VAR@} with arguments $@
+
+if [ -z "${@VAR@}" ]; then
+ # Try to get @VAR@ from system profile
+ @VAR@=$(. /etc/profile >/dev/null 2>&1; echo "${@VAR@}")
+fi
+
+if [ -z "${@VAR@}" ]; then
+ echo "$0: The @VAR@ variable must be set" >&2
+ exit 1
+fi
+
+exec ${@VAR@} "$@"
diff --git a/app-misc/editor-wrapper/metadata.xml b/app-misc/editor-wrapper/metadata.xml
new file mode 100644
index 000000000000..83d335031da4
--- /dev/null
+++ b/app-misc/editor-wrapper/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>base-system</herd>
+<herd>emacs</herd>
+</pkgmetadata>