summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/libguestfs/libguestfs-1.38.6-r1.ebuild')
-rw-r--r--app-emulation/libguestfs/libguestfs-1.38.6-r1.ebuild13
1 files changed, 3 insertions, 10 deletions
diff --git a/app-emulation/libguestfs/libguestfs-1.38.6-r1.ebuild b/app-emulation/libguestfs/libguestfs-1.38.6-r1.ebuild
index 8764f049efc3..aeb2c8d3d6cf 100644
--- a/app-emulation/libguestfs/libguestfs-1.38.6-r1.ebuild
+++ b/app-emulation/libguestfs/libguestfs-1.38.6-r1.ebuild
@@ -3,9 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python3_6 )
-
-inherit autotools bash-completion-r1 eapi7-ver eutils linux-info perl-functions python-single-r1 xdg-utils
+inherit autotools bash-completion-r1 eapi7-ver eutils linux-info perl-functions xdg-utils
MY_PV_1="$(ver_cut 1-2)"
MY_PV_2="$(ver_cut 2)"
@@ -19,11 +17,9 @@ LICENSE="GPL-2 LGPL-2"
SLOT="0/"${MY_PV_1}""
KEYWORDS="~amd64"
-IUSE="doc erlang +fuse gtk inspect-icons introspection libvirt lua ocaml +perl python ruby selinux static-libs systemtap test"
+IUSE="doc erlang +fuse gtk inspect-icons introspection libvirt lua ocaml +perl ruby selinux static-libs systemtap test"
RESTRICT="!test? ( test )"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
# Failures - doc
# FIXME: selinux support is automagic
@@ -59,7 +55,6 @@ COMMON_DEPEND="
>=app-misc/hivex-1.3.1[perl?]
dev-perl/String-ShellQuote
)
- python? ( ${PYTHON_DEPS} )
fuse? ( sys-fs/fuse:= )
introspection? (
>=dev-libs/glib-2.26:2
@@ -110,8 +105,6 @@ PATCHES=(
pkg_setup() {
CONFIG_CHECK="~KVM ~VIRTIO"
[ -n "${CONFIG_CHECK}" ] && check_extra_config;
-
- use python && python-single-r1_pkg_setup
}
src_prepare() {
@@ -137,7 +130,7 @@ src_configure() {
--with-extra="-gentoo" \
--with-readline \
--disable-php \
- $(use_enable python) \
+ --disable-python \
--without-java \
$(use_enable perl) \
$(use_enable fuse) \