summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/zile/zile-2.4.13.ebuild')
-rw-r--r--app-editors/zile/zile-2.4.13.ebuild11
1 files changed, 11 insertions, 0 deletions
diff --git a/app-editors/zile/zile-2.4.13.ebuild b/app-editors/zile/zile-2.4.13.ebuild
index d6136b4f5a1e..52a77f4ede36 100644
--- a/app-editors/zile/zile-2.4.13.ebuild
+++ b/app-editors/zile/zile-2.4.13.ebuild
@@ -33,6 +33,17 @@ src_configure() {
CURSES_LIB="$("$(tc-getPKG_CONFIG)" --libs ncurses)"
}
+src_test() {
+ if tput cup 0 0 >/dev/null || tput cuu1 >/dev/null; then
+ # We have a sane terminal that can move the cursor
+ emake check
+ else
+ ewarn "Terminal type \"${TERM}\" is too stupid to run zile"
+ ewarn "Running the tests with unset TERM instead"
+ ( unset TERM; emake check )
+ fi
+}
+
src_install() {
emake DESTDIR="${D}" install