summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/ulogd/ulogd-2.0.5-r3.ebuild')
-rw-r--r--app-admin/ulogd/ulogd-2.0.5-r3.ebuild18
1 files changed, 11 insertions, 7 deletions
diff --git a/app-admin/ulogd/ulogd-2.0.5-r3.ebuild b/app-admin/ulogd/ulogd-2.0.5-r3.ebuild
index 599d0c949dcc..b39dca2df899 100644
--- a/app-admin/ulogd/ulogd-2.0.5-r3.ebuild
+++ b/app-admin/ulogd/ulogd-2.0.5-r3.ebuild
@@ -9,9 +9,11 @@ AUTOTOOLS_AUTORECONF=1
inherit autotools-utils eutils flag-o-matic linux-info readme.gentoo systemd user
DESCRIPTION="A userspace logging daemon for netfilter/iptables related logging"
-HOMEPAGE="http://netfilter.org/projects/ulogd/index.html"
-SRC_URI="ftp://ftp.netfilter.org/pub/${PN}/${P}.tar.bz2
- http://www.netfilter.org/projects/${PN}/files/${P}.tar.bz2"
+HOMEPAGE="https://netfilter.org/projects/ulogd/index.html"
+SRC_URI="
+ https://www.netfilter.org/projects/${PN}/files/${P}.tar.bz2
+ ftp://ftp.netfilter.org/pub/${PN}/${P}.tar.bz2
+"
LICENSE="GPL-2"
SLOT="0"
@@ -42,9 +44,10 @@ DEPEND="${RDEPEND}
)
"
+DOCS=( AUTHORS README TODO )
+
PATCHES=( "${FILESDIR}/${P}-remove-db-automagic.patch" )
-DOCS=( AUTHORS README TODO )
DOC_CONTENTS="
You must have at least one logging stack enabled to make ulogd work.
Please edit example configuration located at /etc/ulogd.conf
@@ -81,7 +84,7 @@ src_prepare() {
sed -i \
-e 's:var/log:var/log/ulogd:g' \
-e 's:tmp:run:g' \
- ulogd.conf.in || die 'sed on ulogd.conf.in failed'
+ ulogd.conf.in || die
append-lfs-flags
autotools-utils_src_prepare
@@ -126,12 +129,13 @@ src_install() {
use mysql && dodoc doc/mysql-*.sql
use postgres && dodoc doc/pgsql-*.sql
use sqlite && dodoc doc/sqlite3.table
+
doman ${PN}.8
insinto /etc
doins "${BUILD_DIR}/${PN}.conf"
- fowners root:ulogd /etc/ulogd.conf
- fperms 640 /etc/ulogd.conf
+ fowners root:ulogd /etc/${PN}.conf
+ fperms 640 /etc/${PN}.conf
newinitd "${FILESDIR}/${PN}.init-r2" ${PN}
systemd_newunit "${FILESDIR}/${PN}.service-r1" ${PN}.service