summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/hcloud-python/Manifest1
-rw-r--r--dev-python/hcloud-python/hcloud-python-1.26.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/hcloud-python/Manifest b/dev-python/hcloud-python/Manifest
index a801d0c992fc..44bc535ffecd 100644
--- a/dev-python/hcloud-python/Manifest
+++ b/dev-python/hcloud-python/Manifest
@@ -5,3 +5,4 @@ DIST hcloud-python-1.23.0.gh.tar.gz 101752 BLAKE2B 5a8746d7ea58e3ba89271efe54118
DIST hcloud-python-1.23.1.gh.tar.gz 102214 BLAKE2B e8e16a9a4435b579ee7e72738c296b1ee55c15d3868da39c58fcf9489479451e7adfe046696ffd9728a529f60003a4ebe26b0c07f322296ef1e3fe468fe0e9ed SHA512 cf5497b4906cb2abece9afd64fad0aad4deedecafb50f6977c29f0a38951287be07f9f75a18e1ce4cbcedf38261c146236526be7581d8362c6d6ecf7c38992b9
DIST hcloud-python-1.24.0.gh.tar.gz 101860 BLAKE2B f64c0024047b11a060b3766a5692d74c038483ccd25943227931d6ca695be4e7ded7857ccf5d1a8361644b838cee5cd1e5c3ddaaf714ca97b3c0e33f5c3863f2 SHA512 efeb511373009af49b280fa09b152a648d33136c75d12fa69290e2193d5162fb07dea3d457171e0b27c7256f0be63b5c6fb84526cf1e9f32d8c38e350c47686a
DIST hcloud-python-1.25.0.gh.tar.gz 101940 BLAKE2B afc467df0b56b6cea5d413465dcbf12df408a215eee1bf3040abdd062d7548fb6c1c4eb8df4ec381b5969294bb94afc957bba4cf866eaaa6570bc8fd2b45bf68 SHA512 13815d7a61010974f4ecb259ddff8b7ab526114df25bb530e1db38e557499c7bae9a9ecb69c9e625b5bebe8be5c00de166fc421508888f720774288b210db1b4
+DIST hcloud-python-1.26.0.gh.tar.gz 102253 BLAKE2B e5e629218c187e3ffb4f6e30b8963288dbdbfd5f60e20ba60083a5eedc8dc7e94aa917c6b3539a4aaf600d065b771747c7ed8dad7ff41490c9dd7452a0a242f3 SHA512 b2bf656a223c3a8e65b2f641d3a633543a7c5a2bcf0ce31ad9a735115d870affcaa8d0c82758c312b80e130f87259839ce35b918f5762c11a27ecbb1578446d0
diff --git a/dev-python/hcloud-python/hcloud-python-1.26.0.ebuild b/dev-python/hcloud-python/hcloud-python-1.26.0.ebuild
new file mode 100644
index 000000000000..498400383d05
--- /dev/null
+++ b/dev-python/hcloud-python/hcloud-python-1.26.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=hcloud-python-${PV}
+DESCRIPTION="Official Hetzner Cloud python library"
+HOMEPAGE="
+ https://github.com/hetznercloud/hcloud-python/
+ https://pypi.org/project/hcloud/
+"
+# sdist is missing doc assets as of 1.19.0
+# https://github.com/hetznercloud/hcloud-python/pull/183
+SRC_URI="
+ https://github.com/hetznercloud/hcloud-python/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+RDEPEND="
+ >=dev-python/python-dateutil-2.7.5[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.20[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs \
+ dev-python/myst-parser \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # Integration tests need docker:
+ # https://github.com/hetznercloud/hcloud-python/blob/master/.travis.yml#L16
+ tests/integration
+)
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}