summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/meson/meson-0.48.2.ebuild14
-rw-r--r--dev-util/meson/meson-0.49.0.ebuild14
-rw-r--r--dev-util/meson/meson-9999.ebuild14
3 files changed, 33 insertions, 9 deletions
diff --git a/dev-util/meson/meson-0.48.2.ebuild b/dev-util/meson/meson-0.48.2.ebuild
index 1b7da1e7a772..70b182a1276c 100644
--- a/dev-util/meson/meson-0.48.2.ebuild
+++ b/dev-util/meson/meson-0.48.2.ebuild
@@ -19,10 +19,18 @@ HOMEPAGE="http://mesonbuild.com/"
LICENSE="Apache-2.0"
SLOT="0"
-IUSE=""
+IUSE="test"
+RESTIRCT="!test? ( test )"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-libs/glib:2
+ dev-libs/gobject-introspection
+ dev-vcs/git
+ virtual/pkgconfig
+ )
+"
python_prepare_all() {
# ASAN and sandbox both want control over LD_PRELOAD
diff --git a/dev-util/meson/meson-0.49.0.ebuild b/dev-util/meson/meson-0.49.0.ebuild
index 5e725b324a15..31840fa73f4f 100644
--- a/dev-util/meson/meson-0.49.0.ebuild
+++ b/dev-util/meson/meson-0.49.0.ebuild
@@ -19,10 +19,18 @@ HOMEPAGE="http://mesonbuild.com/"
LICENSE="Apache-2.0"
SLOT="0"
-IUSE=""
+IUSE="test"
+RESTIRCT="!test? ( test )"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-libs/glib:2
+ dev-libs/gobject-introspection
+ dev-vcs/git
+ virtual/pkgconfig
+ )
+"
python_prepare_all() {
# ASAN and sandbox both want control over LD_PRELOAD
diff --git a/dev-util/meson/meson-9999.ebuild b/dev-util/meson/meson-9999.ebuild
index 5e725b324a15..31840fa73f4f 100644
--- a/dev-util/meson/meson-9999.ebuild
+++ b/dev-util/meson/meson-9999.ebuild
@@ -19,10 +19,18 @@ HOMEPAGE="http://mesonbuild.com/"
LICENSE="Apache-2.0"
SLOT="0"
-IUSE=""
+IUSE="test"
+RESTIRCT="!test? ( test )"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-libs/glib:2
+ dev-libs/gobject-introspection
+ dev-vcs/git
+ virtual/pkgconfig
+ )
+"
python_prepare_all() {
# ASAN and sandbox both want control over LD_PRELOAD