summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-libs/nghttp3/Manifest1
-rw-r--r--net-libs/nghttp3/nghttp3-1.6.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/net-libs/nghttp3/Manifest b/net-libs/nghttp3/Manifest
index 26fda781349a..c5b5b202a735 100644
--- a/net-libs/nghttp3/Manifest
+++ b/net-libs/nghttp3/Manifest
@@ -1,3 +1,4 @@
DIST nghttp3-1.3.0.tar.xz 390176 BLAKE2B 8ff17da3e53efb27b13e9ab17dba4ca27cc8fd948b160a36a0b0496f61a49c2729f1281f9a29cb8fecd4dd2c274696885a3c5e001be3dcfc30f5f1c9b6339467 SHA512 a862e7a3c3f6722b07d5437976850b2998032d1f7b9da7a49e6863d59c611ff7204c9923e8e570301a9bfbd91931a30f8f85e96cfb35481783adfc2f955a8b8c
DIST nghttp3-1.4.0.tar.xz 389036 BLAKE2B f8292aded56c0778dc285cf7d8261494c89e70e1e2128b0196be97706b1ce45edfd885031d069990429ef82c56c4922e0fe07d7471d4851642ce5e8afaf02bb9 SHA512 39ff9418009dcf84ae58d8297f53427da91509a69ecc4fc78c4c00f0fe6bbe348f7afffeafe535ae4c02ff9f0413016b4f51de6a87d8e8c8f6b415bb7f2b0895
DIST nghttp3-1.5.0.tar.xz 391668 BLAKE2B cbafd1e927bc39db78e238c0a7330170ec8e7a6fad96489fe754088cd40def9ddff7f7eef64bc9dc6efc729acbd4dfe2779bb5ac72092bfe91e3e6aab5b97456 SHA512 76a089fb0dd88b9aced41fccf36758c6504f8faf68c143ca81c260c017ac6dfd83fe678c401304de8bf65e859b0559dc5e8fcb37e88e547076d0ba9fd2c4a59c
+DIST nghttp3-1.6.0.tar.xz 392480 BLAKE2B 43cedaaddaf450a8c3cac4be2353605c85230ef394a94bd40d74f1561fb3593d022f865da41aa05d301de43ccc0aade69f015866cfb93501c4c9083808ef81cf SHA512 d0f585cf388a48d391f803897b0998c12c39e118ca380ecc48c4d3dfd3ff4588a5e456dc89a96f2f5ffd5afc261a2d60a71fd4d8ebb82af35bfe6668737538d8
diff --git a/net-libs/nghttp3/nghttp3-1.6.0.ebuild b/net-libs/nghttp3/nghttp3-1.6.0.ebuild
new file mode 100644
index 000000000000..73e1a756bf6f
--- /dev/null
+++ b/net-libs/nghttp3/nghttp3-1.6.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/ngtcp2/nghttp3.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/ngtcp2/nghttp3/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="amd64 ~arm ~arm64 ~hppa ~loong ppc64 ~riscv ~sparc x86 ~arm64-macos ~x64-macos ~x64-solaris"
+fi
+
+DESCRIPTION="HTTP/3 library written in C"
+HOMEPAGE="https://github.com/ngtcp2/nghttp3/"
+
+LICENSE="MIT"
+SLOT="0/0"
+
+IUSE="static-libs test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="
+ test? ( static-libs )
+"
+
+BDEPEND="virtual/pkgconfig"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DENABLE_LIB_ONLY=ON
+ -DENABLE_STATIC_LIB=$(usex static-libs)
+ -DENABLE_EXAMPLES=OFF
+ )
+ use test && mycmakeargs+=( -DBUILD_TESTING=ON )
+ cmake_src_configure
+}
+
+multilib_src_test() {
+ multilib_is_native_abi && cmake_build check
+}