summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-debug/gfxreconstruct/Manifest2
-rw-r--r--dev-debug/gfxreconstruct/files/1.3.296.0-use-system-vulkan.patch27
-rw-r--r--dev-debug/gfxreconstruct/gfxreconstruct-1.3.296.0.ebuild76
-rw-r--r--dev-debug/gfxreconstruct/gfxreconstruct-9999.ebuild76
-rw-r--r--dev-debug/gfxreconstruct/metadata.xml11
5 files changed, 192 insertions, 0 deletions
diff --git a/dev-debug/gfxreconstruct/Manifest b/dev-debug/gfxreconstruct/Manifest
new file mode 100644
index 000000000000..b6f8db9293ee
--- /dev/null
+++ b/dev-debug/gfxreconstruct/Manifest
@@ -0,0 +1,2 @@
+DIST SPIRV-Reflect-1.3.296.0.tar.gz 306294 BLAKE2B d87677fc67dc55cf10e55f4286300fea5664e870c4d3365246f407514ec682087399c9a06aaa81a88a2f57f6b198de7265ee17dd88215e16e71bb90d32468a4e SHA512 770d46172fed140816dcecc3155bce62ce319f5cbe99bb58e81994e07aed14ebc8f65675c6e47dde2148e2706603ba470f364ab41bcbfbc05c69e25be7c5a898
+DIST gfxreconstruct-1.3.296.0.tar.gz 41585326 BLAKE2B 0b89b4e3be47adbdda45a0e7f14a2176d1ba79980f0c0998c318d1f62c1d4792ddf0db64c125016d531163d8af08d470b9973fc7477ed2a3c05639fe1f1ead2c SHA512 911d2914bbbed24451c1950ac49213cb056db663a6d00557135aec1301ee179ff9c7883b6074db8227cd59100949656e15e53f6b8513cb5d25af4a1fa2ea1f99
diff --git a/dev-debug/gfxreconstruct/files/1.3.296.0-use-system-vulkan.patch b/dev-debug/gfxreconstruct/files/1.3.296.0-use-system-vulkan.patch
new file mode 100644
index 000000000000..27e0fe65e200
--- /dev/null
+++ b/dev-debug/gfxreconstruct/files/1.3.296.0-use-system-vulkan.patch
@@ -0,0 +1,27 @@
+Author: Dylan Aïssi <daissi@debian.org>
+Description: Use system Vulkan Headers instead of embedded ones.
+Last-Update: 2021-06-04
+Forwarded: not-needed
+
+--- a/cmake/FindVulkanVersion.cmake
++++ b/cmake/FindVulkanVersion.cmake
+@@ -9,8 +9,7 @@
+ find_file (VULKAN_HEADER
+ vulkan_core.h
+ HINTS
+- external/Vulkan-Headers/include/vulkan
+- ../external/Vulkan-Headers/include/vulkan)
++ /usr/include/vulkan/)
+
+ MESSAGE(STATUS "Vulkan Header = ${VULKAN_HEADER}")
+
+@@ -20,8 +19,7 @@
+ find_file(VULKAN_HEADER
+ vulkan.h
+ HINTS
+- external/Vulkan-Headers/include/vulkan
+- ../external/Vulkan-Headers/include/vulkan)
++ /usr/include/vulkan/)
+ set(VulkanHeaders_main_header ${VULKAN_HEADER})
+ endif()
+
diff --git a/dev-debug/gfxreconstruct/gfxreconstruct-1.3.296.0.ebuild b/dev-debug/gfxreconstruct/gfxreconstruct-1.3.296.0.ebuild
new file mode 100644
index 000000000000..ddd0350534fb
--- /dev/null
+++ b/dev-debug/gfxreconstruct/gfxreconstruct-1.3.296.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+inherit cmake
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/LunarG/gfxreconstruct.git"
+ EGIT_SUBMODULES=( external/{Vulkan-Headers,SPIRV-Headers,SPIRV-Reflect} )
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/LunarG/${PN}/archive/vulkan-sdk-${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/KhronosGroup/SPIRV-Reflect/archive/vulkan-sdk-${PV}.tar.gz -> SPIRV-Reflect-${PV}.tar.gz
+ "
+ KEYWORDS="~amd64"
+ S="${WORKDIR}"/${PN}-vulkan-sdk-${PV}
+fi
+
+DESCRIPTION="Graphics API Capture and Replay Tools"
+HOMEPAGE="https://github.com/LunarG/gfxreconstruct"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="wayland X"
+
+RDEPEND="
+ app-arch/lz4:=
+ app-arch/zstd:=
+ sys-libs/zlib:=
+
+ media-libs/vulkan-loader[wayland?,X?]
+ wayland? ( dev-libs/wayland )
+ X? (
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/xcb-util-keysyms
+ )
+"
+DEPEND="${RDEPEND}
+ X? ( x11-libs/libXrandr )
+"
+if [[ ${PV} == 9999* ]]; then
+ DEPEND+="
+ ~dev-util/spirv-headers-${PV}
+ ~dev-util/vulkan-headers-${PV}
+ "
+else
+ PATCHES=(
+ "${FILESDIR}"/1.3.296.0-use-system-vulkan.patch
+ )
+fi
+
+src_unpack() {
+ if [[ ${PV} == 9999* ]]; then
+ git-r3_src_unpack
+ else
+ default
+ rmdir "${S}"/external/SPIRV-Reflect || die
+ mv "${WORKDIR}"/SPIRV-Reflect-vulkan-sdk-${PV} "${S}"/external/SPIRV-Reflect || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_SKIP_RPATH=ON
+ -DBUILD_WERROR=OFF
+ -DBUILD_WSI_DISPLAY_SUPPORT=ON
+ -DBUILD_WSI_WAYLAND_SUPPORT=$(usex wayland)
+ -DBUILD_WSI_XCB_SUPPORT=$(usex X)
+ -DBUILD_WSI_XLIB_SUPPORT=$(usex X)
+ )
+ cmake_src_configure
+}
diff --git a/dev-debug/gfxreconstruct/gfxreconstruct-9999.ebuild b/dev-debug/gfxreconstruct/gfxreconstruct-9999.ebuild
new file mode 100644
index 000000000000..ddd0350534fb
--- /dev/null
+++ b/dev-debug/gfxreconstruct/gfxreconstruct-9999.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+inherit cmake
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/LunarG/gfxreconstruct.git"
+ EGIT_SUBMODULES=( external/{Vulkan-Headers,SPIRV-Headers,SPIRV-Reflect} )
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/LunarG/${PN}/archive/vulkan-sdk-${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/KhronosGroup/SPIRV-Reflect/archive/vulkan-sdk-${PV}.tar.gz -> SPIRV-Reflect-${PV}.tar.gz
+ "
+ KEYWORDS="~amd64"
+ S="${WORKDIR}"/${PN}-vulkan-sdk-${PV}
+fi
+
+DESCRIPTION="Graphics API Capture and Replay Tools"
+HOMEPAGE="https://github.com/LunarG/gfxreconstruct"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="wayland X"
+
+RDEPEND="
+ app-arch/lz4:=
+ app-arch/zstd:=
+ sys-libs/zlib:=
+
+ media-libs/vulkan-loader[wayland?,X?]
+ wayland? ( dev-libs/wayland )
+ X? (
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/xcb-util-keysyms
+ )
+"
+DEPEND="${RDEPEND}
+ X? ( x11-libs/libXrandr )
+"
+if [[ ${PV} == 9999* ]]; then
+ DEPEND+="
+ ~dev-util/spirv-headers-${PV}
+ ~dev-util/vulkan-headers-${PV}
+ "
+else
+ PATCHES=(
+ "${FILESDIR}"/1.3.296.0-use-system-vulkan.patch
+ )
+fi
+
+src_unpack() {
+ if [[ ${PV} == 9999* ]]; then
+ git-r3_src_unpack
+ else
+ default
+ rmdir "${S}"/external/SPIRV-Reflect || die
+ mv "${WORKDIR}"/SPIRV-Reflect-vulkan-sdk-${PV} "${S}"/external/SPIRV-Reflect || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_SKIP_RPATH=ON
+ -DBUILD_WERROR=OFF
+ -DBUILD_WSI_DISPLAY_SUPPORT=ON
+ -DBUILD_WSI_WAYLAND_SUPPORT=$(usex wayland)
+ -DBUILD_WSI_XCB_SUPPORT=$(usex X)
+ -DBUILD_WSI_XLIB_SUPPORT=$(usex X)
+ )
+ cmake_src_configure
+}
diff --git a/dev-debug/gfxreconstruct/metadata.xml b/dev-debug/gfxreconstruct/metadata.xml
new file mode 100644
index 000000000000..9b533f1ce767
--- /dev/null
+++ b/dev-debug/gfxreconstruct/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vulkan@gentoo.org</email>
+ <name>Vulkan Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">LunarG/gfxreconstruct</remote-id>
+ </upstream>
+</pkgmetadata>