summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-fs/lvm2/lvm2-2.02.188-r3.ebuild10
-rw-r--r--sys-fs/lvm2/lvm2-2.03.14-r3.ebuild10
2 files changed, 20 insertions, 0 deletions
diff --git a/sys-fs/lvm2/lvm2-2.02.188-r3.ebuild b/sys-fs/lvm2/lvm2-2.02.188-r3.ebuild
index 50111c5fabb3..a7726256c6f8 100644
--- a/sys-fs/lvm2/lvm2-2.02.188-r3.ebuild
+++ b/sys-fs/lvm2/lvm2-2.02.188-r3.ebuild
@@ -266,6 +266,10 @@ pkg_postinst() {
tmpfiles_process lvm2.conf
fi
+ if use udev; then
+ udev_reload
+ fi
+
if [[ -z "${REPLACING_VERSIONS}" ]]; then
# This is a new installation
ewarn "Make sure the \"lvm\" init script is in the runlevels:"
@@ -292,6 +296,12 @@ pkg_postinst() {
fi
}
+pkg_postrm() {
+ if use udev && [[ -z ${REPLACING_VERSIONS} ]]; then
+ udev_reload
+ fi
+}
+
src_test() {
einfo "Tests are disabled because of device-node mucking, if you want to"
einfo "run tests, compile the package and see ${S}/tests"
diff --git a/sys-fs/lvm2/lvm2-2.03.14-r3.ebuild b/sys-fs/lvm2/lvm2-2.03.14-r3.ebuild
index 281599b2fdf0..3c36db1adc1f 100644
--- a/sys-fs/lvm2/lvm2-2.03.14-r3.ebuild
+++ b/sys-fs/lvm2/lvm2-2.03.14-r3.ebuild
@@ -268,6 +268,10 @@ pkg_postinst() {
tmpfiles_process lvm2.conf
fi
+ if use udev; then
+ udev_reload
+ fi
+
if [[ -z "${REPLACING_VERSIONS}" ]]; then
# This is a new installation
ewarn "Make sure the \"lvm\" init script is in the runlevels:"
@@ -294,6 +298,12 @@ pkg_postinst() {
fi
}
+pkg_postrm() {
+ if use udev && [[ -z ${REPLACING_VERSIONS} ]]; then
+ udev_reload
+ fi
+}
+
src_test() {
einfo "Tests are disabled because of device-node mucking, if you want to"
einfo "run tests, compile the package and see ${S}/tests"