summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ada/aunit/aunit-24.0.0-r1.ebuild (renamed from dev-ada/aunit/aunit-24.0.0.ebuild)17
-rw-r--r--dev-ada/aunit/files/aunit-24.0.0-gentoo.patch35
2 files changed, 50 insertions, 2 deletions
diff --git a/dev-ada/aunit/aunit-24.0.0.ebuild b/dev-ada/aunit/aunit-24.0.0-r1.ebuild
index c31c1793e16c..09130deee820 100644
--- a/dev-ada/aunit/aunit-24.0.0.ebuild
+++ b/dev-ada/aunit/aunit-24.0.0-r1.ebuild
@@ -14,6 +14,7 @@ SRC_URI="https://github.com/AdaCore/${PN}/archive/refs/tags/v${PV}.tar.gz
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+IUSE="doc"
RDEPEND="${ADA_DEPS}"
DEPEND="${RDEPEND}
@@ -21,15 +22,27 @@ DEPEND="${RDEPEND}
REQUIRED_USE="${ADA_REQUIRED_USE}"
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+
+src_prepare() {
+ default
+ sed -i \
+ -e "s|@PF@|${PF}|g" \
+ lib/gnat/aunit.gpr \
+ || die
+}
+
src_compile() {
emake GPROPTS_EXTRA="-j$(makeopts_jobs) -v -cargs ${ADAFLAGS}"
+ if use doc; then
+ emake -C doc html-all
+ emake -C doc txt-all
+ fi
}
src_install() {
emake INSTALL="${D}"/usr install
einstalldocs
- mv "${D}"/usr/share/examples/${PN} "${D}"/usr/share/doc/${PF}/examples || die
- rmdir "${D}"/usr/share/examples || die
rm -r "${D}"/usr/share/gpr/manifests || die
}
diff --git a/dev-ada/aunit/files/aunit-24.0.0-gentoo.patch b/dev-ada/aunit/files/aunit-24.0.0-gentoo.patch
new file mode 100644
index 000000000000..934e49b6153c
--- /dev/null
+++ b/dev-ada/aunit/files/aunit-24.0.0-gentoo.patch
@@ -0,0 +1,35 @@
+--- a/lib/gnat/aunit.gpr 2022-12-19 22:08:42.000000000 +0100
++++ b/lib/gnat/aunit.gpr 2024-03-01 22:32:34.298510972 +0100
+@@ -50,16 +50,16 @@
+
+ package Install is
+ for Artifacts ("share/doc/aunit/pdf")
+- use ("../../doc/pdf/**");
+- for Artifacts ("share/doc/aunit/txt")
+- use ("../../doc/txt/**");
++ use ("../../doc/build/aunit_cb/pdf/**");
++ for Artifacts ("share/doc/@PF@")
++ use ("../../doc/build/aunit_cb/txt/**");
+ for Artifacts ("share/doc/aunit/info")
+- use ("../../doc/info/**");
+- for Artifacts ("share/doc/aunit/html")
+- use ("../../doc/html/**");
++ use ("../../doc/build/aunit_cb/info/**");
++ for Artifacts ("share/doc/@PF@/html")
++ use ("../../doc/build/aunit_cb/html/**");
+
+ for Artifacts ("share/gps/plug-ins") use ("../../support/aunit.xml");
+- for Artifacts ("share/examples/aunit") use ("../../examples/*");
++ for Artifacts ("share/doc/@PF@/examples") use ("../../examples/*");
+ end Install;
+
+ end AUnit;
+--- a/doc/share/conf.py 2024-03-01 22:35:22.194546565 +0100
++++ b/doc/share/conf.py 2024-03-01 22:35:34.657400722 +0100
+@@ -95,6 +95,3 @@
+ u'AdaCore', doc_name, doc_name, '')]
+
+
+-def setup(app):
+- app.add_lexer('ada', ada_pygments.AdaLexer())
+- app.add_lexer('gpr', ada_pygments.GNATProjectLexer())