summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-misc/xcave/files/xcave-2.4.0-pkg-config.patch13
-rw-r--r--x11-misc/xcave/xcave-2.4.0.ebuild26
2 files changed, 35 insertions, 4 deletions
diff --git a/x11-misc/xcave/files/xcave-2.4.0-pkg-config.patch b/x11-misc/xcave/files/xcave-2.4.0-pkg-config.patch
new file mode 100644
index 000000000000..f0e331dccfe2
--- /dev/null
+++ b/x11-misc/xcave/files/xcave-2.4.0-pkg-config.patch
@@ -0,0 +1,13 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -49,10 +49,6 @@
+
+
+
+-PKG_CHECK_MODULES(libxml-2.0, libxml-2.0)
+-AC_SUBST(libxml-2.0_CFLAGS)
+-AC_SUBST(libxml-2.0_LIBS)
+-
+ AC_OUTPUT([
+ Makefile
+ src/Makefile
diff --git a/x11-misc/xcave/xcave-2.4.0.ebuild b/x11-misc/xcave/xcave-2.4.0.ebuild
index 3e6245d4498d..96c74893f67f 100644
--- a/x11-misc/xcave/xcave-2.4.0.ebuild
+++ b/x11-misc/xcave/xcave-2.4.0.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit autotools flag-o-matic
DESCRIPTION="View and manage contents of your wine cellar"
HOMEPAGE="http://xcave.free.fr/index-en.php"
@@ -14,13 +15,30 @@ RESTRICT="test"
RDEPEND="
x11-libs/gtk+:2
- dev-libs/libxml2:2"
-DEPEND="${RDEPEND}"
+ dev-libs/libxml2:2
+"
+DEPEND="
+ ${RDEPEND}
+"
BDEPEND="
dev-util/intltool
sys-devel/gettext
- virtual/pkgconfig"
+ virtual/pkgconfig
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.4.0-pkg-config.patch
+)
+src_prepare() {
+ mkdir m4 || die
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-cflags -fcommon
+ default
+}
src_install() {
default