summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-emulation/ppsspp/files/ppsspp-1.5.4-stdint-gcc-10.patch10
-rw-r--r--games-emulation/ppsspp/ppsspp-1.5.4-r2.ebuild3
2 files changed, 12 insertions, 1 deletions
diff --git a/games-emulation/ppsspp/files/ppsspp-1.5.4-stdint-gcc-10.patch b/games-emulation/ppsspp/files/ppsspp-1.5.4-stdint-gcc-10.patch
new file mode 100644
index 000000000000..0a7c45a810b2
--- /dev/null
+++ b/games-emulation/ppsspp/files/ppsspp-1.5.4-stdint-gcc-10.patch
@@ -0,0 +1,10 @@
+--- a/Common/Hashmaps.h
++++ b/Common/Hashmaps.h
+@@ -2,6 +2,7 @@
+
+ #include <cstring>
+ #include <vector>
++#include <stdint.h> /* uint32_t */
+
+ #include "ext/xxhash.h"
+ #include "Common/CommonFuncs.h"
diff --git a/games-emulation/ppsspp/ppsspp-1.5.4-r2.ebuild b/games-emulation/ppsspp/ppsspp-1.5.4-r2.ebuild
index 4e7f8f7f0271..8de0ecaf7478 100644
--- a/games-emulation/ppsspp/ppsspp-1.5.4-r2.ebuild
+++ b/games-emulation/ppsspp/ppsspp-1.5.4-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -50,6 +50,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.4.2-assets-lookup.patch
"${FILESDIR}"/${PN}-1.4-O2.patch
"${FILESDIR}"/${P}-ffmpeg-4.patch
+ "${FILESDIR}"/${P}-stdint-gcc-10.patch
)
src_unpack() {