summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-03 14:54:10 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-03 14:55:06 +0200
commita25fa4b7f9c36a1413a839e8d5334071a01b257e (patch)
tree225ad2def1485e768d51e557f4e2469ef02c64db /xfce-base
parentsci-libs/safetensors: add 0.4.5 (diff)
downloadgentoo-a25fa4b7f9c36a1413a839e8d5334071a01b257e.tar.gz
gentoo-a25fa4b7f9c36a1413a839e8d5334071a01b257e.tar.bz2
gentoo-a25fa4b7f9c36a1413a839e8d5334071a01b257e.zip
xfce-base/xfdesktop: Bump to 4.19.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/xfdesktop/Manifest1
-rw-r--r--xfce-base/xfdesktop/xfdesktop-4.19.4.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/xfce-base/xfdesktop/Manifest b/xfce-base/xfdesktop/Manifest
index 9835281e4fcd..3a048620ba4f 100644
--- a/xfce-base/xfdesktop/Manifest
+++ b/xfce-base/xfdesktop/Manifest
@@ -1,2 +1,3 @@
DIST xfdesktop-4.18.1.tar.bz2 2133258 BLAKE2B 3d4f54b64a6adc5f52bf6b48862b1fbf9b9608113035fdce89a2cb08a674f773f42edc0e1d05a27e89de7df71f7d53f400b794a2a79888cf51570c3ab060db8b SHA512 cafb1e274bbabf1704a6452532fc79657af26eaf92a58374f87a70f31c35fbf213319c6658b3d18bfca2d555b69e07e46949407d1f80e5a37f48e76bbde9dc3e
DIST xfdesktop-4.19.3.tar.bz2 2532496 BLAKE2B 8269bdd216a25a69ffa7c3200454403209d9b3409ce506a79b7cfdaccfbc3d64c0b5576767f21d1afb6f69f271f186209c940350332876b022bb5433ea047b01 SHA512 e14ec75215bd1f2ec276f9d15836f3a73072f07972191e77631e99150cc61ad87fd1291fcdcd9069f4656f9a20175d25b9d43a381d459a27b0c28b481a9739c9
+DIST xfdesktop-4.19.4.tar.bz2 1917525 BLAKE2B eac15e57c4e711bbdbd7aa1a8037ffa2e9e7709557c477254107dbca8f68d8dc61ef653991aaed06c50a439ad81759a6fb9987dddbf94da27cf3e2a5fa9f444b SHA512 a3d323f60fc8edd2f3c83ffef95421e8af93c30dcbc85ce0a3ca5f2e9c1e42e121e608e9e0f29b8f7809495a90a29e4c1bfaa4dc4fe76b26c69b928eba2e0753
diff --git a/xfce-base/xfdesktop/xfdesktop-4.19.4.ebuild b/xfce-base/xfdesktop/xfdesktop-4.19.4.ebuild
new file mode 100644
index 000000000000..47318b4265c4
--- /dev/null
+++ b/xfce-base/xfdesktop/xfdesktop-4.19.4.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="Desktop manager for the Xfce desktop environment"
+HOMEPAGE="
+ https://docs.xfce.org/xfce/xfdesktop/start
+ https://gitlab.xfce.org/xfce/xfdesktop/
+"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+# CC for /usr/share/backgrounds, see backgrounds/README.md
+LICENSE="GPL-2+ CC-BY-SA-4.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="libnotify +thunar wayland X"
+REQUIRED_USE="|| ( wayland X )"
+
+DEPEND="
+ >=x11-libs/cairo-1.16
+ >=dev-libs/glib-2.74.0
+ >=x11-libs/gtk+-3.24.0:3[wayland?,X?]
+ >=xfce-base/exo-0.11:=
+ >=xfce-base/garcon-0.6:=
+ >=xfce-base/libxfce4ui-4.18.0:=
+ >=xfce-base/libxfce4util-4.13:=
+ >=xfce-base/libxfce4windowing-4.19.3:=[X?]
+ >=xfce-base/xfconf-4.18.0:=
+ libnotify? ( >=x11-libs/libnotify-0.7:= )
+ thunar? (
+ >=dev-libs/libyaml-0.2.5:=
+ >=xfce-base/thunar-4.17.10:=
+ )
+ wayland? ( >=gui-libs/gtk-layer-shell-0.7.0 )
+ X? ( >=x11-libs/libX11-1.6.7 )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-libs/glib
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable wayland)
+ $(use_enable X x11)
+ $(use_enable thunar file-icons)
+ $(use_enable thunar thunarx)
+ $(use_enable libnotify notifications)
+ # these aren't run via make check, they are only for manual use
+ --disable-tests
+ )
+
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}