summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-15 15:31:25 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-15 16:03:48 +0100
commit38485b26d712db64f4b21d16b01262ada3b4ba1d (patch)
tree50e5bfa63dcb576324698f6a3d3760a93c6177a2 /xfce-base
parentxfce-base/garcon: Remove old (diff)
downloadgentoo-38485b26d712db64f4b21d16b01262ada3b4ba1d.tar.gz
gentoo-38485b26d712db64f4b21d16b01262ada3b4ba1d.tar.bz2
gentoo-38485b26d712db64f4b21d16b01262ada3b4ba1d.zip
xfce-base/garcon: Bump to 4.18.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/garcon/Manifest1
-rw-r--r--xfce-base/garcon/garcon-4.18.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/xfce-base/garcon/Manifest b/xfce-base/garcon/Manifest
index 8687afc6bca8..6e4c0e2702e9 100644
--- a/xfce-base/garcon/Manifest
+++ b/xfce-base/garcon/Manifest
@@ -1,2 +1,3 @@
DIST garcon-0.8.0.tar.bz2 539061 BLAKE2B 8d7b207fdb325d060c3ecfa5e2574961082706c5a4af59cabebad9d3c915228085dc32442521018bfb7da2d3c169445ac270c00c381e666bfda8774329a60cfc SHA512 708c68c31c0d3d89ecdde4790594837af0d065ecb805131fd7db2eb4c433c0523f44d51f2040f7bf9af729537e5f9e89ed06a435fc0c4e6113db00ad78ba8ce0
DIST garcon-4.17.3.tar.bz2 550490 BLAKE2B 78b7f0770cdb6a6dd1e08b7732e8c31f13a9b424e588740f37dbbb7233df28b8dfd73d099c678f2bdeaa5a850fcbb707187ba54b1277e0a28e801d6eecc1c2cf SHA512 fef686854b5005d94dbf455e08a24313d014e6ee410509038b7b08a1ea64836cb2b196ca0ccceef341b132f35b64c11b784ae9f02dc4e2b3bb2faa473eb7bce1
+DIST garcon-4.18.0.tar.bz2 550674 BLAKE2B 93bc218c4455c61109ee7086a8cb822aaa154aaebd082c10ae9fd551019bce0fe68a117552c05fbe3a97c671036b5306703ba3c320d9b886715a83fb038c95b0 SHA512 c4b49ba47ac33823199a68ef9bdcba3acfcedde62a96a8a8b3af2bb1f28b3a5fe3e960ee93bdb964fbc01b039047d77f58fbe5b1f9fbd2ccd3d3f968e416a55c
diff --git a/xfce-base/garcon/garcon-4.18.0.ebuild b/xfce-base/garcon/garcon-4.18.0.ebuild
new file mode 100644
index 000000000000..5bf287cfc158
--- /dev/null
+++ b/xfce-base/garcon/garcon-4.18.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="Xfce's freedesktop.org specification compatible menu implementation library"
+HOMEPAGE="
+ https://docs.xfce.org/xfce/garcon/start
+ https://gitlab.xfce.org/xfce/garcon/
+"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2+ FDL-1.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="introspection"
+
+DEPEND="
+ >=dev-libs/glib-2.66.0
+ >=x11-libs/gtk+-3.24.0:3
+ >=xfce-base/libxfce4util-4.15.6:=[introspection?]
+ >=xfce-base/libxfce4ui-4.15.7:=[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-1.66:= )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/glib-utils
+ dev-util/gtk-doc-am
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ introspection? ( >=dev-libs/gobject-introspection-1.66 )
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}