summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2020-01-26 09:08:10 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2020-01-26 09:09:37 +0100
commite0c95359c4daa4ef7c21fe025347b7a12a941161 (patch)
tree52b9e15d0cfe4c18513c2c41c1de3a80c9395fb6 /x11-wm
parentdev-ruby/thread_order: cleanup (diff)
downloadgentoo-e0c95359c4daa4ef7c21fe025347b7a12a941161.tar.gz
gentoo-e0c95359c4daa4ef7c21fe025347b7a12a941161.tar.bz2
gentoo-e0c95359c4daa4ef7c21fe025347b7a12a941161.zip
x11-wm/xpra: Version bump
Also simplify useflags a bit. Closes: https://bugs.gentoo.org/695140 Package-Manager: Portage-2.3.85, Repoman-2.3.20 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/xpra/Manifest1
-rw-r--r--x11-wm/xpra/xpra-3.0.5.ebuild144
2 files changed, 145 insertions, 0 deletions
diff --git a/x11-wm/xpra/Manifest b/x11-wm/xpra/Manifest
index 8366143c6459..fe93a815ba36 100644
--- a/x11-wm/xpra/Manifest
+++ b/x11-wm/xpra/Manifest
@@ -2,3 +2,4 @@ DIST xpra-2.2.2.tar.xz 2195836 BLAKE2B 39d8354738df399d98248a0d455c3b7fa6124f374
DIST xpra-2.2.6.tar.xz 2198720 BLAKE2B 41f238e98dbb60598cffcc3960375a525658c72db478acace0acb964fe3ee039acb5e352a76ffb5724b6c4acd63ea510505f6841f688c67d0ae2a3cbc2270642 SHA512 f47b7a8b08fc90bdf3cba91e4f7343785cdf6e24a0979f4564e9f6885b0f36c03ff5656e2d7ac5fd21895faca7b00e8839ebd66c82122a2c7cab2b40bd44e745
DIST xpra-2.4.3.tar.xz 2434852 BLAKE2B 3d2dd4d8a64a20a88004a91f95d8e6165f45dac7a3d725f41c437d605f55bbd903284e7e829e02c1e94e33c3777ce660c55b469fb5b1f6c5025853b0cae1a6c3 SHA512 5174f7852571eaeb6c2fb629aa2686e19bff7251622ff08903af188989f132b73e4509c98edfac9cddd0f582e63d0ffae94442111a7bfcef8013b3fc87dffd54
DIST xpra-3.0.2.tar.xz 2749196 BLAKE2B 3c8745657a12637704fb88ac7b867ab387ef7ed2250396d9e534aecf81e40f85332a2c51ba49638834012f4a4d85c03bd7e49ee259bb2400aeb60fb06abf8b59 SHA512 115f606ff5886d99a906f318cb1a7a4a86e80ebf23e4336e67938267d92ef624de577cc8fc06c6ce541b7c44a0cef58d930b5928f32e24dfc67c72127c7b623c
+DIST xpra-3.0.5.tar.xz 2752016 BLAKE2B a36d6a4ebb0b14665014da92d510c0d5f978c96db653709ddc09a1015426d6ac6f71f9a221db68ee1114c95eeaca6600f9e49102ce9f936d9b0ee298ac432647 SHA512 3dbc122ebc8c4aa67154acfe92668ac364d8469022b03e28946d763e4d396f8c707690b2a4dbf07b55545259a53b46c9dd94e6e40131289ccc3dce6a88107681
diff --git a/x11-wm/xpra/xpra-3.0.5.ebuild b/x11-wm/xpra/xpra-3.0.5.ebuild
new file mode 100644
index 000000000000..b22b25da4bf4
--- /dev/null
+++ b/x11-wm/xpra/xpra-3.0.5.ebuild
@@ -0,0 +1,144 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# PyCObject_Check and PyCObject_AsVoidPtr vanished with python 3.3
+PYTHON_COMPAT=( python3_{6,7} )
+inherit xdg distutils-r1 eutils flag-o-matic user tmpfiles prefix
+
+DESCRIPTION="X Persistent Remote Apps (xpra) and Partitioning WM (parti) based on wimpiggy"
+HOMEPAGE="http://xpra.org/ http://xpra.org/src/"
+SRC_URI="http://xpra.org/src/${P}.tar.xz"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+client +clipboard csc cups dbus ffmpeg jpeg libav +lz4 lzo opengl pillow pulseaudio server sound test vpx webcam webp"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
+ || ( client server )
+ cups? ( dbus )
+ opengl? ( client )
+"
+
+COMMON_DEPEND="${PYTHON_DEPS}
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/libXtst
+ x11-libs/libxkbfile
+ csc? (
+ !libav? ( >=media-video/ffmpeg-1.2.2:0= )
+ libav? ( media-video/libav:0= )
+ )
+ ffmpeg? (
+ !libav? ( >=media-video/ffmpeg-3.2.2:0=[x264,x265] )
+ libav? ( media-video/libav:0=[x264,x265] )
+ )
+ jpeg? ( media-libs/libjpeg-turbo )
+ opengl? ( dev-python/pyopengl )
+ pulseaudio? ( media-sound/pulseaudio )
+ sound? ( media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ dev-python/gst-python:1.0 )
+ vpx? ( media-libs/libvpx virtual/ffmpeg )
+ webp? ( media-libs/libwebp )
+"
+RDEPEND="${COMMON_DEPEND}
+ dev-python/netifaces[${PYTHON_USEDEP}]
+ dev-python/rencode[${PYTHON_USEDEP}]
+ dev-python/pillow[jpeg?,${PYTHON_USEDEP}]
+ virtual/ssh
+ x11-apps/xmodmap
+ cups? ( dev-python/pycups[${PYTHON_USEDEP}] )
+ dbus? ( dev-python/dbus-python[${PYTHON_USEDEP}] )
+ lz4? ( dev-python/lz4[${PYTHON_USEDEP}] )
+ lzo? ( >=dev-python/python-lzo-0.7.0[${PYTHON_USEDEP}] )
+ opengl? (
+ client? ( dev-python/pyopengl_accelerate[${PYTHON_USEDEP}] )
+ )
+ server? ( x11-base/xorg-server[-minimal,xvfb]
+ x11-drivers/xf86-input-void
+ )
+ webcam? ( dev-python/numpy[${PYTHON_USEDEP}]
+ media-libs/opencv[python]
+ dev-python/pyinotify[${PYTHON_USEDEP}] )"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ >=dev-python/cython-0.16[${PYTHON_USEDEP}]"
+
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.0.2_ignore-gentoo-no-compile.patch
+ "${FILESDIR}"/${PN}-2.0-suid-warning.patch
+ "${FILESDIR}"/${PN}-3.0.2-ldconfig.patch
+)
+
+pkg_postinst() {
+ enewgroup ${PN}
+ tmpfiles_process /usr/lib/tmpfiles.d/xpra.conf
+
+ xdg_pkg_postinst
+}
+
+python_prepare_all() {
+ use dbus || eapply "${FILESDIR}/${PN}-3.0.2-dbus.patch"
+
+ hprefixify -w '/os.path/' setup.py
+ hprefixify tmpfiles.d/xpra.conf xpra/server/server_util.py \
+ xpra/platform{/xposix,}/paths.py xpra/scripts/server.py
+
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ sed -e "/'pulseaudio'/s:DEFAULT_PULSEAUDIO:$(usex pulseaudio True False):" \
+ -i setup.py || die
+
+ mydistutilsargs=(
+ --without-PIC
+ --without-Xdummy
+ $(use_with client)
+ $(use_with clipboard)
+ $(use_with csc csc_swscale)
+ --without-csc_libyuv
+ --without-cuda_rebuild
+ --without-cuda_kernels
+ $(use_with cups printing)
+ --without-debug
+ $(use_with dbus)
+ $(use_with ffmpeg dec_avcodec2)
+ $(use_with ffmpeg enc_ffmpeg)
+ $(use_with ffmpeg enc_x264)
+ $(use_with ffmpeg enc_x265)
+ --without-gtk2
+ --with-gtk3
+ --without-html5
+ $(use_with jpeg jpeg_encoder)
+ $(use_with jpeg jpeg_decoder)
+ --without-mdns
+ --without-minify
+ $(use_with opengl)
+ $(use_with server shadow)
+ $(use_with server)
+ $(use_with sound)
+ --with-strict
+ $(use_with vpx)
+ --with-warn
+ $(use_with webcam)
+ $(use_with webp)
+ --with-x11
+ )
+
+ # see https://www.xpra.org/trac/ticket/1080
+ # and http://trac.cython.org/ticket/395
+ append-cflags -fno-strict-aliasing
+
+ export XPRA_SOCKET_DIRS="${EPREFIX}/run/xpra"
+}