summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-10-11 10:48:44 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-10-11 10:48:44 +0100
commit1ce14fb1660a6ec86050ca280a459a01bdb69309 (patch)
treedea22a402c3abb005657219ca7d348519bf0ca86 /x11-wm
parentx11-misc/util-macros: lookup tool-prefixed 'cpp' (diff)
downloadgentoo-1ce14fb1660a6ec86050ca280a459a01bdb69309.tar.gz
gentoo-1ce14fb1660a6ec86050ca280a459a01bdb69309.tar.bz2
gentoo-1ce14fb1660a6ec86050ca280a459a01bdb69309.zip
x11-wm/fluxbox: fix build on c++17 compiler (gcc-11)
Reported-by: lekto@o2.pl Closes: https://bugs.gentoo.org/732782 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/fluxbox/files/fluxbox-1.3.7-c++17.patch28
-rw-r--r--x11-wm/fluxbox/fluxbox-1.3.7-r4.ebuild4
2 files changed, 32 insertions, 0 deletions
diff --git a/x11-wm/fluxbox/files/fluxbox-1.3.7-c++17.patch b/x11-wm/fluxbox/files/fluxbox-1.3.7-c++17.patch
new file mode 100644
index 000000000000..37e450b08f16
--- /dev/null
+++ b/x11-wm/fluxbox/files/fluxbox-1.3.7-c++17.patch
@@ -0,0 +1,28 @@
+http://git.fluxbox.org/fluxbox.git/patch/?id=22866c4d30f5b289c429c5ca88d800200db4fc4f
+https://bugs.gentoo.org/732782
+
+From 22866c4d30f5b289c429c5ca88d800200db4fc4f Mon Sep 17 00:00:00 2001
+From: John Sennesael <john@aminking.com>
+Date: Mon, 2 Nov 2015 15:14:32 -0600
+Subject: fixes bug #1138
+
+---
+ util/fluxbox-remote.cc | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/util/fluxbox-remote.cc b/util/fluxbox-remote.cc
+index 59852e6..504015b 100644
+--- a/util/fluxbox-remote.cc
++++ b/util/fluxbox-remote.cc
+@@ -73,7 +73,7 @@ int main(int argc, char **argv) {
+ if (strcmp(cmd, "result") == 0) {
+ XTextProperty text_prop;
+ if (XGetTextProperty(disp, root, &text_prop, atom_result) != 0
+- && text_prop.value > 0
++ && text_prop.value != 0
+ && text_prop.nitems > 0) {
+
+ printf("%s", text_prop.value);
+--
+cgit v0.11.2
+
diff --git a/x11-wm/fluxbox/fluxbox-1.3.7-r4.ebuild b/x11-wm/fluxbox/fluxbox-1.3.7-r4.ebuild
index 762963c89327..1acca6751070 100644
--- a/x11-wm/fluxbox/fluxbox-1.3.7-r4.ebuild
+++ b/x11-wm/fluxbox/fluxbox-1.3.7-r4.ebuild
@@ -34,6 +34,10 @@ BDEPEND="bidi? ( virtual/pkgconfig )
DEPEND="${RDEPEND}
x11-base/xorg-proto"
+PATCHES=(
+ "${FILESDIR}"/${P}-c++17.patch
+)
+
src_prepare() {
default
# We need to be able to include directories rather than just plain