summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2024-05-28 09:54:36 +0200
committerFlorian Schmaus <flow@gentoo.org>2024-05-28 09:54:36 +0200
commit1228c5e43cede0083c776882ecd569715d72080b (patch)
tree1ffc0def4269754d63c59f5747904dc1682ebedb /x11-wm
parentgnome-base/gnome-flashback: Bump to 3.52.1 (diff)
downloadgentoo-1228c5e43cede0083c776882ecd569715d72080b.tar.gz
gentoo-1228c5e43cede0083c776882ecd569715d72080b.tar.bz2
gentoo-1228c5e43cede0083c776882ecd569715d72080b.zip
x11-wm/metacity: add 3.52.0
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/metacity/Manifest1
-rw-r--r--x11-wm/metacity/metacity-3.52.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/x11-wm/metacity/Manifest b/x11-wm/metacity/Manifest
index 29e6cccb32ad..27adb737324c 100644
--- a/x11-wm/metacity/Manifest
+++ b/x11-wm/metacity/Manifest
@@ -1,2 +1,3 @@
DIST metacity-3.46.1.tar.xz 1959060 BLAKE2B 84dbe09dd8d6c7ce1894ed806cdc6cc5cc6c302ddf3aae5f7ef479f6c02ef6c2091bb1d815603f5d6e52d583192d43f47d835327e9e75cd626081becbf84bd8e SHA512 f0d8424868edf8209eb4cbd003de68ab892a5b515a1aca7b3626bf52eb8451cb0477ab35f702177c9654604e06adce46471897edcb54931d95e60b36bef92b20
DIST metacity-3.50.0.tar.xz 1959172 BLAKE2B a697bb0d820211abdd212a250d0ea6a698962b37b9e200c54dab51ca11bb1c9a65708dd8f098211d3d451da83f484d549f5fc33c63f391f42744a8046849ccd7 SHA512 2fd66f96b0603dfea652ad21f9749c3dbd68c847cda884a0e16f23766c9b61fcdfa693dcb83beb33c909487a7d9f7f5eb796096cfc772cc44c4b267ef1b08699
+DIST metacity-3.52.0.tar.xz 1960156 BLAKE2B e8d078f08c4d3a40a98b5d95aa0286adc4da518ca6a495768d9e31626862b03a3ad5da26928ccc3f337b9811fd5ffa927a37e5f9ab6a7b7c256052842207b5cf SHA512 e49c8a45a26b9b43700e50787fef9e02a6c5abc5d8a809542acaf32f6e15ea756bf8398883e3c69707908e8556ae726d9764fc09f07b0beaa40f79a1490c361e
diff --git a/x11-wm/metacity/metacity-3.52.0.ebuild b/x11-wm/metacity/metacity-3.52.0.ebuild
new file mode 100644
index 000000000000..3158e3f409bf
--- /dev/null
+++ b/x11-wm/metacity/metacity-3.52.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome2
+
+DESCRIPTION="GNOME Flashback window manager"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/metacity/"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="+libcanberra vulkan xinerama"
+KEYWORDS="~amd64 ~riscv"
+
+# TODO: libgtop could be optional, but no knob
+RDEPEND="
+ >=dev-libs/glib-2.67.3:2
+ >=x11-libs/gtk+-3.24.6:3[X]
+ >=x11-libs/pango-1.2.0
+ >=x11-libs/libXcomposite-0.3
+ >=x11-libs/libXres-1.2
+ >=gnome-base/gsettings-desktop-schemas-3.3.0
+ x11-libs/libXfixes
+ x11-libs/libXrender
+ x11-libs/libXdamage
+ x11-libs/libXpresent
+ libcanberra? ( media-libs/libcanberra[gtk3] )
+ >=x11-libs/startup-notification-0.7
+ x11-libs/libXcursor
+ gnome-base/libgtop:2=
+ x11-libs/libX11
+ xinerama? ( x11-libs/libXinerama )
+ x11-libs/libXrandr
+ x11-libs/libXext
+ x11-libs/libICE
+ x11-libs/libSM
+ gnome-extra/zenity
+ vulkan? ( media-libs/vulkan-loader )
+"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="
+ vulkan? ( dev-util/vulkan-headers )
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.6
+ virtual/pkgconfig
+" # autoconf-archive for eautoreconf
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable libcanberra canberra) \
+ $(use_enable xinerama) \
+ $(use_enable vulkan)
+}