summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2023-05-14 15:41:38 +0100
committerJames Le Cuirot <chewi@gentoo.org>2023-05-14 15:53:29 +0100
commit15bcf35582bb7ad431835dbea82c2aada2ec32a3 (patch)
tree843963de7bc1e59d81a79274ea080ae8c44055d9 /x11-wm/xpra
parentx11-wm/xpra: Don't use reserved TDEPEND variable name (diff)
downloadgentoo-15bcf35582bb7ad431835dbea82c2aada2ec32a3.tar.gz
gentoo-15bcf35582bb7ad431835dbea82c2aada2ec32a3.tar.bz2
gentoo-15bcf35582bb7ad431835dbea82c2aada2ec32a3.zip
x11-wm/xpra: Update 9999 for latest changes
Some tests are failing, but I can't figure out why. Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'x11-wm/xpra')
-rw-r--r--x11-wm/xpra/files/xpra-4.5-no-service.patch19
-rw-r--r--x11-wm/xpra/files/xpra-9999-tests.patch34
-rw-r--r--x11-wm/xpra/files/xpra-9999-xdummy.patch26
-rw-r--r--x11-wm/xpra/metadata.xml1
-rw-r--r--x11-wm/xpra/xpra-9999.ebuild14
5 files changed, 69 insertions, 25 deletions
diff --git a/x11-wm/xpra/files/xpra-4.5-no-service.patch b/x11-wm/xpra/files/xpra-4.5-no-service.patch
new file mode 100644
index 000000000000..329c492784ac
--- /dev/null
+++ b/x11-wm/xpra/files/xpra-4.5-no-service.patch
@@ -0,0 +1,19 @@
+Don't install the service files. Auto-detection is used to determine what files
+to install, and where, which can be unpredictable on Gentoo. The init.d script
+is also not suitable for Gentoo.
+
+diff --git a/setup.py b/setup.py
+index 529b591b1..ad23d6ecc 100755
+--- a/setup.py
++++ b/setup.py
+@@ -187,8 +187,8 @@ rfb_ENABLED = DEFAULT
+ quic_ENABLED = DEFAULT
+ ssh_ENABLED = DEFAULT
+ http_ENABLED = DEFAULT
+-service_ENABLED = LINUX and server_ENABLED
+-sd_listen_ENABLED = POSIX and pkg_config_ok("--exists", "libsystemd")
++service_ENABLED = False
++sd_listen_ENABLED = False
+ proxy_ENABLED = DEFAULT
+ client_ENABLED = DEFAULT
+ scripts_ENABLED = not WIN32
diff --git a/x11-wm/xpra/files/xpra-9999-tests.patch b/x11-wm/xpra/files/xpra-9999-tests.patch
new file mode 100644
index 000000000000..746966577dcd
--- /dev/null
+++ b/x11-wm/xpra/files/xpra-9999-tests.patch
@@ -0,0 +1,34 @@
+From 79573c7f1241225922bee992f2caaf730cfbe3ac Mon Sep 17 00:00:00 2001
+From: totaam <antoine@xpra.org>
+Date: Sun, 9 Oct 2022 21:37:39 +0700
+Subject: [PATCH 3/3] Revert "don't use GLib directly"
+
+This reverts commit bc8bf26c44d1b151d709232460483f5432f79f5b.
+---
+ xpra/server/mixins/child_command_server.py | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/xpra/server/mixins/child_command_server.py b/xpra/server/mixins/child_command_server.py
+index 8dea3c1f7..1c2a60e27 100644
+--- a/xpra/server/mixins/child_command_server.py
++++ b/xpra/server/mixins/child_command_server.py
+@@ -11,6 +11,8 @@ import os.path
+ from time import monotonic
+ from subprocess import Popen
+
++from gi.repository import GLib
++
+ from xpra.platform.features import COMMAND_SIGNALS
+ from xpra.child_reaper import getChildReaper, reaper_cleanup
+ from xpra.os_util import (
+@@ -72,7 +74,7 @@ class ChildCommandServer(StubServerMixin):
+ #even if __init__ is called multiple times:
+ if not getattr(self, "late_start_requested", False):
+ self.late_start_requested = True
+- self.idle_add(self.late_start)
++ GLib.idle_add(self.late_start)
+
+ def late_start(self):
+ def do_late_start():
+--
+2.38.0
diff --git a/x11-wm/xpra/files/xpra-9999-xdummy.patch b/x11-wm/xpra/files/xpra-9999-xdummy.patch
index 2326e63498ce..b86f0dda45fe 100644
--- a/x11-wm/xpra/files/xpra-9999-xdummy.patch
+++ b/x11-wm/xpra/files/xpra-9999-xdummy.patch
@@ -1,24 +1,14 @@
-From 7c384b517fb391065b84b60fa8f1ec3338ed4fce Mon Sep 17 00:00:00 2001
-From: James Le Cuirot <chewi@gentoo.org>
-Date: Sat, 16 Apr 2022 22:30:11 +0100
-Subject: [PATCH] Avoid Xdummy version detection, assume 0.4.0
-
----
- setup.py | 1 +
- 1 file changed, 1 insertion(+)
+Avoid Xdummy version detection, assume 0.4.1.
diff --git a/setup.py b/setup.py
-index 40bfba61c..e4636cb46 100755
+index 529b591b1..b9431fea8 100755
--- a/setup.py
+++ b/setup.py
-@@ -657,6 +657,7 @@ def get_gcc_version():
- return GCC_VERSION
-
+@@ -793,6 +793,7 @@ def vernum(s):
+ return tuple(int(v) for v in s.split("-", 1)[0].split("."))
+
def get_dummy_driver_version():
-+ return (0, 4)
- def vernum(s):
- return tuple(int(v) for v in s.split("-", 1)[0].split("."))
++ return "0.4.1"
#try various rpm names:
---
-2.34.1
-
+ for rpm_name in ("xorg-x11-drv-dummy", "xf86-video-dummy"):
+ r, out, err = get_status_output(["rpm", "-q", "--queryformat", "%{VERSION}", rpm_name])
diff --git a/x11-wm/xpra/metadata.xml b/x11-wm/xpra/metadata.xml
index 230b35b55f48..308083d50825 100644
--- a/x11-wm/xpra/metadata.xml
+++ b/x11-wm/xpra/metadata.xml
@@ -24,6 +24,7 @@
<flag name="csc">Enable csc softscaler support</flag>
<flag name="html">Install the HTML5 client</flag>
<flag name="ibus">Use ibus input method via <pkg>app-i18n/ibus</pkg></flag>
+ <flag name="oauth">Enable OAuth2 authentication in the server</flag>
<flag name="pillow">Enable pillow support</flag>
<flag name="pinentry">Use <pkg>app-crypt/pinentry</pkg> for password entry</flag>
<flag name="server">Build server-side code</flag>
diff --git a/x11-wm/xpra/xpra-9999.ebuild b/x11-wm/xpra/xpra-9999.ebuild
index 2d2f17c05900..c4e11b241ef1 100644
--- a/x11-wm/xpra/xpra-9999.ebuild
+++ b/x11-wm/xpra/xpra-9999.ebuild
@@ -21,11 +21,12 @@ DESCRIPTION="X Persistent Remote Apps (xpra) and Partitioning WM (parti) based o
HOMEPAGE="https://xpra.org/"
LICENSE="GPL-2 BSD"
SLOT="0"
-IUSE="brotli +client +clipboard crypt csc cups dbus doc ffmpeg jpeg html ibus +lz4 lzo minimal opengl pillow pinentry pulseaudio +server sound systemd test udev vpx webcam webp xdg xinerama"
+IUSE="brotli +client +clipboard crypt csc cups dbus doc ffmpeg jpeg html ibus +lz4 lzo minimal oauth opengl pillow pinentry pulseaudio +server sound systemd test udev vpx webcam webp xdg xinerama"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
|| ( client server )
cups? ( dbus )
+ oauth? ( server )
opengl? ( client )
test? ( client clipboard crypt dbus html server sound xdg xinerama )
"
@@ -84,9 +85,8 @@ RDEPEND="
cups? ( dev-python/pycups[${PYTHON_USEDEP}] )
lz4? ( dev-python/lz4[${PYTHON_USEDEP}] )
lzo? ( >=dev-python/python-lzo-0.7.0[${PYTHON_USEDEP}] )
- opengl? (
- client? ( dev-python/pyopengl_accelerate[${PYTHON_USEDEP}] )
- )
+ oauth? ( dev-python/oauthlib[${PYTHON_USEDEP}] )
+ opengl? ( dev-python/pyopengl_accelerate[${PYTHON_USEDEP}] )
webcam? (
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/pyinotify[${PYTHON_USEDEP}]
@@ -115,9 +115,9 @@ BDEPEND="
RESTRICT="!test? ( test )"
PATCHES=(
- "${FILESDIR}"/${PN}-3.0.2_ignore-gentoo-no-compile.patch
- "${FILESDIR}"/${PN}-4.3-no-service.patch
+ "${FILESDIR}"/${PN}-4.5-no-service.patch
"${FILESDIR}"/${PN}-9999-xdummy.patch
+ "${FILESDIR}"/${PN}-9999-tests.patch
)
python_prepare_all() {
@@ -144,6 +144,7 @@ python_configure_all() {
DISTUTILS_ARGS=(
--without-PIC
--without-Xdummy
+ $(use_with sound audio)
$(use_with client)
$(use_with clipboard)
$(use_with csc csc_swscale)
@@ -165,7 +166,6 @@ python_configure_all() {
$(use_with opengl)
$(use_with server shadow)
$(use_with server)
- $(use_with sound)
--with-strict
$(use_with vpx)
--with-warn