summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-wm/wmii
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-wm/wmii')
-rw-r--r--x11-wm/wmii/Manifest1
-rw-r--r--x11-wm/wmii/files/wmii.desktop7
-rw-r--r--x11-wm/wmii/metadata.xml14
-rw-r--r--x11-wm/wmii/wmii-3.9.2-r4.ebuild79
4 files changed, 101 insertions, 0 deletions
diff --git a/x11-wm/wmii/Manifest b/x11-wm/wmii/Manifest
new file mode 100644
index 000000000000..22036072c585
--- /dev/null
+++ b/x11-wm/wmii/Manifest
@@ -0,0 +1 @@
+DIST wmii+ixp-3.9.2.tbz 432032 SHA256 0466f1a5c534b0ee9fdace2c7a2d251845b7ec0ae80bdb8e68ae6584ebeebf2b SHA512 c75d6d3f80e2b263c8d7b9eb6d0e700a1ad642209fc0984908e9399d22372c6c0572f47ab61881d5d56c4cc4eeb2914a545f6af1bbb936b65848764577d75761 WHIRLPOOL 241d72da4cc1d55772f04143a4696a12a013870d1aa63b622fa086a85b093a66d343dee2414d7f121ff13321bc0dfaf3bb60180c2f8ef58bd3357e12fcc64686
diff --git a/x11-wm/wmii/files/wmii.desktop b/x11-wm/wmii/files/wmii.desktop
new file mode 100644
index 000000000000..45dc8235e17b
--- /dev/null
+++ b/x11-wm/wmii/files/wmii.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Name=wmii
+Comment=window manager improved 2
+Exec=wmii
+TryExec=wmii
+Icon=
+Type=Application
diff --git a/x11-wm/wmii/metadata.xml b/x11-wm/wmii/metadata.xml
new file mode 100644
index 000000000000..874e3abac105
--- /dev/null
+++ b/x11-wm/wmii/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+ <longdescription lang="en">
+ wmii is a dynamic window manager for X11. It is highly customizable and
+ usable with keyboard and mouse. It supports conventional, tabbed and
+ tiled window management and has a small memory footprint. It is highly
+ modularized and uses an inter-process communication interface which
+ conforms to the 9P2000 protocol introduced by the Plan 9 operating
+ system.
+ </longdescription>
+</pkgmetadata>
+
diff --git a/x11-wm/wmii/wmii-3.9.2-r4.ebuild b/x11-wm/wmii/wmii-3.9.2-r4.ebuild
new file mode 100644
index 000000000000..4ec8fb279fb6
--- /dev/null
+++ b/x11-wm/wmii/wmii-3.9.2-r4.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit flag-o-matic multilib toolchain-funcs
+
+MY_P=wmii+ixp-${PV}
+
+DESCRIPTION="A dynamic window manager for X11"
+HOMEPAGE="http://wmii.suckless.org/"
+SRC_URI="http://dl.suckless.org/wmii/${MY_P}.tbz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+COMMON_DEPEND="
+ >=sys-libs/libixp-0.5_p20110208-r3
+ x11-libs/libXft
+ x11-libs/libXext
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libX11
+ x11-libs/libXinerama
+ >=media-libs/freetype-2
+"
+RDEPEND="${COMMON_DEPEND}
+ x11-apps/xmessage
+ x11-apps/xsetroot
+ media-fonts/font-misc-misc
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+"
+
+S=${WORKDIR}/${MY_P}
+
+# Force dynamic linking, bug #273332
+MAKEOPTS="${MAKEOPTS} STATIC= -j1"
+
+src_prepare() {
+ mywmiiconf=(
+ PREFIX=/usr
+ DOC=/usr/share/doc/${PF}
+ ETC=/etc
+ LIBDIR=/usr/$(get_libdir)
+ CC="$(tc-getCC) -c"
+ LD="$(tc-getCC)"
+ AR="$(tc-getAR) crs"
+ DESTDIR="${D}"
+ LIBIXP=/usr/$(get_libdir)/libixp.so
+ )
+
+ # punt internal copy of sys-libs/libixp #323037
+ rm -f include/ixp{,_srvutil}.h || die
+ sed -i -e '/libixp/d' Makefile || die
+
+ sed -i -e "/BINSH \!=/d" mk/hdr.mk || die #335083
+ sed -i -e 's/-lXext/& -lXrender -lX11/' cmd/Makefile || die #369115
+}
+
+src_compile() {
+ append-flags -I/usr/include/freetype2
+ emake "${mywmiiconf[@]}"
+}
+
+src_install() {
+ emake "${mywmiiconf[@]}" install
+ dodoc NEWS NOTES README TODO
+
+ echo wmii > "${T}"/wmii
+ exeinto /etc/X11/Sessions
+ doexe "${T}"/wmii
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}"/${PN}.desktop
+}