summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-09-03 16:50:46 -0300
committerMatt Turner <mattst88@gentoo.org>2023-09-03 20:48:12 -0400
commit73487def743e1d518a202d04af60b6b60c9a163b (patch)
tree6701c46d9165b8bf3665fd5c0e6f1d13711f9371 /x11-themes/adwaita-icon-theme
parentx11-themes/gnome-backgrounds: Version bump to 45_rc (diff)
downloadgentoo-73487def743e1d518a202d04af60b6b60c9a163b.tar.gz
gentoo-73487def743e1d518a202d04af60b6b60c9a163b.tar.bz2
gentoo-73487def743e1d518a202d04af60b6b60c9a163b.zip
x11-themes/adwaita-icon-theme: Version bump to 45_rc
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/32590 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-themes/adwaita-icon-theme')
-rw-r--r--x11-themes/adwaita-icon-theme/Manifest1
-rw-r--r--x11-themes/adwaita-icon-theme/adwaita-icon-theme-45_rc.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/x11-themes/adwaita-icon-theme/Manifest b/x11-themes/adwaita-icon-theme/Manifest
index ff69071b5289..28a323b52c33 100644
--- a/x11-themes/adwaita-icon-theme/Manifest
+++ b/x11-themes/adwaita-icon-theme/Manifest
@@ -1,3 +1,4 @@
DIST adwaita-icon-theme-3.32.0.tar.xz 18540012 BLAKE2B a82ca6758cdbf459ac617d3b3d834e4147c3a3c5e6ca7c705ed2d16e8cf0a1255f5ae999d7e930b9716585b8c498c220f1ab40fec929dde7679efd56f3b18a45 SHA512 9609732cd51c6794d4d86598818bb2a589b0f4b6b795e57f3507dad69b21ef1b2fc2e83e24e937428bbace32fcccf587a5771cbc02c5768206e704f0456a6d1d
DIST adwaita-icon-theme-44.0.tar.xz 2488628 BLAKE2B fdea82299d7d0344a782f6153d2d4a0680930057877adf67ff6cbf26b94ed71b5c4c84a0025b5db671652cda3ab508daf1e1c513991682f7a810bed0aac9b81b SHA512 987245be4e9118ea1d3d56f2829b03a311a29e58e99a51949f3592f0c57f0ce9fe8636215efcd7de2e25a3a005c6df91d780d69ddae1e59f3a5f2edcd0a502be
+DIST adwaita-icon-theme-45.rc.tar.xz 4294164 BLAKE2B e9ee1863f8034b396b47b33f32465db87006d405c8eecedab46be935789cb6ecea2d72014f4ad4b9d7c5f15088493d8fdbdd671f3228af0effe020635293288e SHA512 cd602f852a98f280bba3145164ec8ff452b8275d9b0add877caf676bc54c2941fd4233fc264d9d8861adffd946981e90d0504a43e0a29b421ef918fc9dabe59d
DIST tango-gentoo-v1.1.tar.gz 29322 BLAKE2B 83fa2bf37727e60851dd679054fe1b153ebfea58c9a9a40f891f7d68d3b047b02e8effa1d1b4e08d64500a2072ce7200f159c92a352da7124de27e1b05bb6027 SHA512 87d47ddab68361db6d99866c51705dcb3e198f8345a1096859acf2c6cca5099dd23c7fb30d124f52c4933ea38fd45fadffbbe6ecbdfa84f5b60938a4824f9045
diff --git a/x11-themes/adwaita-icon-theme/adwaita-icon-theme-45_rc.ebuild b/x11-themes/adwaita-icon-theme/adwaita-icon-theme-45_rc.ebuild
new file mode 100644
index 000000000000..49b93ffd47ba
--- /dev/null
+++ b/x11-themes/adwaita-icon-theme/adwaita-icon-theme-45_rc.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson xdg
+
+DESCRIPTION="GNOME default icon theme"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/adwaita-icon-theme"
+
+SRC_URI="${SRC_URI}
+ branding? ( https://www.mail-archive.com/tango-artists@lists.freedesktop.org/msg00043/tango-gentoo-v1.1.tar.gz )
+"
+LICENSE="
+ || ( LGPL-3 CC-BY-SA-3.0 )
+ branding? ( CC-BY-SA-4.0 )
+"
+SLOT="0"
+IUSE="branding"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+# gtk+:3 is needed for build for the gtk-encode-symbolic-svg utility
+# librsvg is needed for gtk-encode-symbolic-svg to be able to read the source SVG via
+# its pixbuf loader and at runtime for rendering scalable icons shipped by the theme
+DEPEND=">=x11-themes/hicolor-icon-theme-0.10"
+RDEPEND="${DEPEND}
+ >=gnome-base/librsvg-2.48:2
+"
+BDEPEND="
+ >=gnome-base/librsvg-2.48:2
+ sys-devel/gettext
+ virtual/pkgconfig
+ x11-libs/gtk+:3
+"
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip"
+
+src_prepare() {
+ if use branding; then
+ for i in 16; do
+ cp "${WORKDIR}"/tango-gentoo-v1.1/${i}x${i}/gentoo.png \
+ "${S}"/Adwaita/${i}x${i}/places/start-here.png \
+ || die "Copying gentoo logos failed"
+ done
+ cp "${WORKDIR}"/tango-gentoo-v1.1/scalable/gentoo.svg \
+ "${S}"/Adwaita/scalable/places/start-here.svg || die
+ fi
+
+ default
+}
+
+src_test() {
+ :; # No tests
+}
+
+src_install() {
+ meson_src_install
+
+ # Gentoo uses the following location for cursors too, but keep
+ # upstream path to prevent issues like bugs #838451, #834277, #834001
+ dosym ../../../../usr/share/icons/Adwaita/cursors /usr/share/cursors/xorg-x11/Adwaita
+}
+
+pkg_preinst() {
+ # Needed until bug #834600 is solved
+ if [[ -d "${EROOT}"/usr/share/cursors/xorg-x11/Adwaita ]] ; then
+ rm -r "${EROOT}"/usr/share/cursors/xorg-x11/Adwaita || die
+ fi
+ xdg_pkg_preinst
+}