summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-10-29 02:52:37 +0000
committerSam James <sam@gentoo.org>2024-10-29 02:52:37 +0000
commit39ead14b2a39c7c7b8666483fc5fea82c0cb7985 (patch)
tree4f214fb1f7ae039243ab7939f8dcf85059625082 /x11-terms
parentsys-process/parallel: add 20241022 (diff)
downloadgentoo-39ead14b2a39c7c7b8666483fc5fea82c0cb7985.tar.gz
gentoo-39ead14b2a39c7c7b8666483fc5fea82c0cb7985.tar.bz2
gentoo-39ead14b2a39c7c7b8666483fc5fea82c0cb7985.zip
x11-terms/xterm: add 395
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/xterm/Manifest2
-rw-r--r--x11-terms/xterm/xterm-395.ebuild110
2 files changed, 112 insertions, 0 deletions
diff --git a/x11-terms/xterm/Manifest b/x11-terms/xterm/Manifest
index 54f74cc7ce1d..7b51cd03e3f2 100644
--- a/x11-terms/xterm/Manifest
+++ b/x11-terms/xterm/Manifest
@@ -10,3 +10,5 @@ DIST xterm-393.tgz 1587657 BLAKE2B 795ce24cb72d376b375ef741eb6d8976151923dbf8043
DIST xterm-393.tgz.asc 729 BLAKE2B 70cdc7903b864d242ae2e8b41e328147b76c3a88cf87d416f13828a0038509ee9c1def0d450c1bbf3d389a45e7abcc1091ed050bb247af1d1cb4000c568f0d85 SHA512 bf3a1fde22164f7ceca6bf817ed9039f013aaa68b6f7033be2c614457caf3b3affefc74edefdeab1263f4bb4937f054b4d48f3cf89f258bd823380c53d55d370
DIST xterm-394.tgz 1590462 BLAKE2B 860d2eb32f68dc09cfb78bd0510751d847b8722674d7b846a93569f2a6e846934c4a25c4eb973419c723a757430f155d5507236998984bfbc159ebb1a23f89d7 SHA512 46989632c94506b4e86690eeebf07524a88f2850ea5fb48d0d7505d2d2241ec6ba6c3cf09baec8a5dce5531a1ef23560b1e4456fbf1dae1077e15ab69bf18e04
DIST xterm-394.tgz.asc 729 BLAKE2B daa6710dceedbea84671d33ed6e08c4d73fb63f3c4de2c9a0b792e295be3c65f96758540b82c1dc1b01c2aa20d9ee19953bf6d98047636c725cdf871cd6635d0 SHA512 71540cf4f79d5e0fdd41625f002a6cc2d0c41ef0078f483956e00ded0a5906054e0902327d1af723c57003ad8d69507a6dcccf9ad6d99eb71e128b49dd856ca1
+DIST xterm-395.tgz 1580365 BLAKE2B 8183da30b491a0e43c34e2728586816e733a18aa8bf87d0ec60b43d47d625bc07395886b02afe08260cc527bc3efa67d04cb060254f0b9ffb7e5ff29b187f42f SHA512 a617f684f1e71eb7b7d33c505f408b90feaac604aa4ea70cb24d9b4eb78242f0eb4545aea81abcb2c51379ad54aa113ec88d445a9d290d5ff141ab0f1a009952
+DIST xterm-395.tgz.asc 729 BLAKE2B f87f732939a52aac55b51a0296144c600d87dca10c5140c39fa0c259e300a8bafe64721aa2c392bcb925521956eb55d11a9be21f6b21112b161db974f4442672 SHA512 c636e13e5c1122d3e9eeb92e013dbb8e9fedc25a7a42b2f2220b33a6a62ea37ae454e97447c65790b454b2c5fda074845e196339a3c861e01013739808dfccf2
diff --git a/x11-terms/xterm/xterm-395.ebuild b/x11-terms/xterm/xterm-395.ebuild
new file mode 100644
index 000000000000..066ba983d50d
--- /dev/null
+++ b/x11-terms/xterm/xterm-395.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/thomasdickey.asc
+inherit desktop flag-o-matic toolchain-funcs verify-sig xdg
+
+DESCRIPTION="Terminal Emulator for X Windows"
+HOMEPAGE="https://invisible-island.net/xterm/"
+SRC_URI="https://invisible-island.net/archives/${PN}/${P}.tgz"
+SRC_URI+=" verify-sig? ( https://invisible-island.net/archives/${PN}/${P}.tgz.asc )"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="+openpty sixel toolbar truetype unicode Xaw3d xinerama"
+
+DEPEND="
+ kernel_linux? ( sys-libs/libutempter )
+ media-libs/fontconfig:1.0
+ >=sys-libs/ncurses-5.7-r7:=
+ x11-apps/xmessage
+ x11-libs/libICE
+ x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXft
+ x11-libs/libxkbfile
+ x11-libs/libXmu
+ x11-libs/libXrender
+ x11-libs/libXt
+ unicode? ( x11-apps/luit )
+ Xaw3d? ( x11-libs/libXaw3d )
+ xinerama? ( x11-libs/libXinerama )"
+RDEPEND="${DEPEND}
+ media-fonts/font-misc-misc
+ x11-apps/rgb"
+DEPEND+=" x11-base/xorg-proto"
+BDEPEND="
+ virtual/pkgconfig
+ verify-sig? ( sec-keys/openpgp-keys-thomasdickey )
+"
+
+DOCS=( README{,.i18n} ctlseqs.txt )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-384-unconditional-gnusource.patch
+)
+
+src_configure() {
+ DEFAULTS_DIR="${EPREFIX}"/usr/share/X11/app-defaults
+
+ # bug #454736
+ # Workaround for ncurses[tinfo] until upstream fixes their buildsystem using
+ # something sane like pkg-config or ncurses5-config and stops guessing libs
+ # Everything gets linked against ncurses anyways, so don't shout
+ append-libs $($(tc-getPKG_CONFIG) --libs ncurses)
+
+ local myeconfargs=(
+ --disable-full-tgetent
+ --disable-imake
+ --disable-setgid
+ --disable-setuid
+ --enable-256-color
+ --enable-broken-osc
+ --enable-broken-st
+ --enable-dabbrev
+ --enable-exec-xterm
+ --enable-i18n
+ --enable-load-vt-fonts
+ --enable-logging
+ --enable-screen-dumps
+ --enable-warnings
+ --enable-wide-chars
+ --libdir="${EPREFIX}"/etc
+ --with-app-defaults="${DEFAULTS_DIR}"
+ --with-icon-theme=hicolor
+ --with-icondir="${EPREFIX}"/usr/share/icons
+ --with-utempter
+ --with-x
+ $(use_enable openpty)
+ $(use_enable sixel sixel-graphics)
+ $(use_enable toolbar)
+ $(use_enable truetype freetype)
+ $(use_enable unicode luit)
+ $(use_enable unicode mini-luit)
+ $(use_with Xaw3d)
+ $(use_with xinerama)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ docinto html
+ dodoc xterm.log.html
+ sed -i -e 's/_48x48//g' *.desktop || die
+ domenu *.desktop
+
+ # Fix permissions -- it grabs them from live system, and they can
+ # be suid or sgid like they were in pre-unix98 pty or pre-utempter days,
+ # respectively (#69510).
+ # (info from Thomas Dickey) - Donnie Berkholz <spyderous@gentoo.org>
+ fperms 0755 /usr/bin/xterm
+
+ # restore the navy blue
+ sed -i -e 's:blue2$:blue:' "${D}${DEFAULTS_DIR}"/XTerm-color || die
+}