summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-10-05 10:42:38 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-10-05 11:20:52 -0400
commit0d95da460dc98e1ee12be1ba4870ae90635785aa (patch)
tree90b1d56e53ac5532ddb89ece53aecaffb0dfae95 /x11-terms/kitty-shell-integration
parentapp-portage/elogv: Drop old (diff)
downloadgentoo-0d95da460dc98e1ee12be1ba4870ae90635785aa.tar.gz
gentoo-0d95da460dc98e1ee12be1ba4870ae90635785aa.tar.bz2
gentoo-0d95da460dc98e1ee12be1ba4870ae90635785aa.zip
x11-terms/kitty-shell-integration: add 0.30.1
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-terms/kitty-shell-integration')
-rw-r--r--x11-terms/kitty-shell-integration/Manifest1
-rw-r--r--x11-terms/kitty-shell-integration/files/kitty-0.30.1-no-sudo.patch21
-rw-r--r--x11-terms/kitty-shell-integration/kitty-shell-integration-0.30.1.ebuild41
3 files changed, 63 insertions, 0 deletions
diff --git a/x11-terms/kitty-shell-integration/Manifest b/x11-terms/kitty-shell-integration/Manifest
index ee9130cd7f99..d739243daaf3 100644
--- a/x11-terms/kitty-shell-integration/Manifest
+++ b/x11-terms/kitty-shell-integration/Manifest
@@ -1,2 +1,3 @@
DIST kitty-0.29.2.tar.xz 7809388 BLAKE2B 6928d79a6cc0eaac4d92ce3babbeb0a42bf1dbc92b775386b521c8399352ba77ab9828f8cfd9f40c3e4f29ae98852b6f3cb9ee1f412474ba2ef655c18d2c294d SHA512 a34d8b5bc817dd9d27f1afa190856d916576f52458ede2253655b294358b6b89b1f103acb90d8d66a494b346420ddedc9fcf1a3399f561268ded82e7b1954b06
DIST kitty-0.30.0.tar.xz 7842724 BLAKE2B a656fbb74a92a6b834fe8d06a89eaa1240044b132d64d7ad9eb429c71fd60e564ed963638bb9ba4e99d3e31c2ac594543e702b298a0b53aea1050e3b2e19ae9a SHA512 05438de8752057d7c419da41621b4d8fcfa6e7189530efc32c7c8a0bf2e6dae0332dd1b661206f9dea5bf374713e86ea5e69f640b0e73fe617f528bc963a8792
+DIST kitty-0.30.1.tar.xz 7799076 BLAKE2B 99ada03fa957819e716d3225fbee20af62135ff8861d3a6ce8aaf442b4526a69f34dae0ec126db48a4336fcbd2dfde5583e2ff8f16140e938fada6c0a8854a60 SHA512 e5fd68b8acf3eae8f53a2c27101d998eb0d8eff1571de1b03ab431bceafcab0efae821590684ec48b5ed6e3d86fb984d9e04784022ba50c0378d37a68598f9ed
diff --git a/x11-terms/kitty-shell-integration/files/kitty-0.30.1-no-sudo.patch b/x11-terms/kitty-shell-integration/files/kitty-0.30.1-no-sudo.patch
new file mode 100644
index 000000000000..d22bca5de0b5
--- /dev/null
+++ b/x11-terms/kitty-shell-integration/files/kitty-0.30.1-no-sudo.patch
@@ -0,0 +1,21 @@
+Ensure no sudo wrapper given may easily result in an error with no permission
+to set TERMINFO. Normally disabled by "no-sudo" but depending on load ordering
+or user configs overwriting that without disabling it as well, it could give
+poor surprises.
+
+Not needed on Gentoo given have a kitty-terminfo package installed in standard
+paths without needing TERMINFO set.
+--- a/shell-integration/bash/kitty.bash
++++ b/shell-integration/bash/kitty.bash
+@@ -215,4 +214,0 @@
+- if [[ "${_ksi_prompt[sudo]}" == "y" ]]; then
+- # Ensure terminfo is available in sudo
+- [[ -n "$TERMINFO" ]] && builtin alias sudo="sudo TERMINFO=\"$TERMINFO\""
+- fi
+--- a/shell-integration/zsh/kitty-integration
++++ b/shell-integration/zsh/kitty-integration
+@@ -391,4 +390,0 @@
+- if (( ! opt[(Ie)no-sudo] )); then
+- # Ensure terminfo is available in sudo
+- [[ -n "$TERMINFO" ]] && builtin alias sudo="sudo TERMINFO=\"$TERMINFO\""
+- fi
diff --git a/x11-terms/kitty-shell-integration/kitty-shell-integration-0.30.1.ebuild b/x11-terms/kitty-shell-integration/kitty-shell-integration-0.30.1.ebuild
new file mode 100644
index 000000000000..17f4df44ff93
--- /dev/null
+++ b/x11-terms/kitty-shell-integration/kitty-shell-integration-0.30.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Shell integration scripts for kitty, a GPU-based terminal emulator"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
+S="${WORKDIR}/kitty-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+RESTRICT="test" # intended to be ran on the full kitty package
+
+PATCHES=(
+ "${FILESDIR}"/kitty-0.30.1-no-sudo.patch
+)
+
+src_compile() { :; }
+
+src_install() {
+ # install the whole directory in the upstream suggested location
+ # for consistency (i.e. less variation between distros if someone
+ # ssh into Gentoo), then set symlinks to autoload where possible
+ # (these exit immediately if KITTY_SHELL_INTEGRATION is unset)
+ insinto /usr/share/kitty
+ doins -r shell-integration
+
+ dosym -r {/usr/share/kitty/shell-integration/bash,/etc/bash/bashrc.d}/kitty.bash
+
+ dosym -r /usr/share/{kitty/shell-integration/fish,fish}/vendor_completions.d/kitty.fish
+ dosym -r /usr/share/{kitty/shell-integration/fish,fish}/vendor_conf.d/kitty-shell-integration.fish
+
+ dosym -r /usr/share/{kitty/shell-integration/zsh/completions,zsh/site-functions}/_kitty
+ # zsh integration is handled automatically without needing to modify rc files,
+ # but may require user intervention depending on zsh invocation or if remote
+
+ # this is used internally by the ssh kitten and is not useful there
+ rm -r "${ED}"/usr/share/kitty/shell-integration/ssh || die
+}