summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/wmmldonkey
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/wmmldonkey')
-rw-r--r--x11-plugins/wmmldonkey/Manifest1
-rw-r--r--x11-plugins/wmmldonkey/metadata.xml5
-rw-r--r--x11-plugins/wmmldonkey/wmmldonkey-0.003-r1.ebuild46
3 files changed, 52 insertions, 0 deletions
diff --git a/x11-plugins/wmmldonkey/Manifest b/x11-plugins/wmmldonkey/Manifest
new file mode 100644
index 000000000000..06645a8813ac
--- /dev/null
+++ b/x11-plugins/wmmldonkey/Manifest
@@ -0,0 +1 @@
+DIST wmmldonkey3.tar.gz 18684 SHA256 053bf2557e489bd526cdf3f4e6d28429d41c6a70ac677b89728dceab61eb04f5 SHA512 7026db45230a5b78788a6562e0a06a61cbdbbb794b52c81e8a7cd734e82605bf6c96d1528b48c1c6991dd76efc03391d01e7a90e49caae8d49ae8cbafb8c963c WHIRLPOOL 0bb0d620e668499a047e3bf120ab965ed17d5a68e2393c5efbdfc56e71671d5558e37028fb2c53242f01ad5e978d6be52cc8fb1955f3000e86495a517c7d49d8
diff --git a/x11-plugins/wmmldonkey/metadata.xml b/x11-plugins/wmmldonkey/metadata.xml
new file mode 100644
index 000000000000..ca551894a934
--- /dev/null
+++ b/x11-plugins/wmmldonkey/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-dock</herd>
+</pkgmetadata>
diff --git a/x11-plugins/wmmldonkey/wmmldonkey-0.003-r1.ebuild b/x11-plugins/wmmldonkey/wmmldonkey-0.003-r1.ebuild
new file mode 100644
index 000000000000..c82362251396
--- /dev/null
+++ b/x11-plugins/wmmldonkey/wmmldonkey-0.003-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="wmmsg is a dockapp to show the up and downloadrate from your mldonkey"
+HOMEPAGE="http://dockapps.windowmaker.org/file.php/id/174"
+SRC_URI="http://dockapps.windowmaker.org/download.php/id/298/wmmldonkey3.tar.gz"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="
+ x11-libs/libXext
+ x11-libs/libX11
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ net-p2p/mldonkey"
+
+S=${WORKDIR}/wmmldonkey3
+
+src_prepare() {
+ sed \
+ -e 's:gcc:${CC} ${CFLAGS}:' \
+ -e 's:gui_protocol.o endianess.o::' \
+ -e 's:main.c -o wmmldonkey:main.c gui_protocol.o endianess.o -o wmmldonkey:' \
+ -e 's:-lXpm -lXext:-lX11 -lXpm -lXext:' \
+ -i "${S}/Makefile" || die
+
+ tc-export CC
+}
+
+src_install() {
+ dodoc CHANGELOG README
+ dobin wmmldonkey
+}
+
+pkg_postinst() {
+ elog "Make sure the mldonkey daemon is running before you"
+ elog "attempt to run emmldonkey..."
+}