summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/wmitime
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/wmitime')
-rw-r--r--x11-plugins/wmitime/Manifest2
-rw-r--r--x11-plugins/wmitime/files/makefile.diff26
-rw-r--r--x11-plugins/wmitime/metadata.xml10
-rw-r--r--x11-plugins/wmitime/wmitime-0.3.ebuild40
-rw-r--r--x11-plugins/wmitime/wmitime-0.4.ebuild34
5 files changed, 112 insertions, 0 deletions
diff --git a/x11-plugins/wmitime/Manifest b/x11-plugins/wmitime/Manifest
new file mode 100644
index 000000000000..409c8ea7f944
--- /dev/null
+++ b/x11-plugins/wmitime/Manifest
@@ -0,0 +1,2 @@
+DIST wmitime-0.3.tar.gz 21442 SHA256 fcec441bac183ac2fbbbf9d577c2eaaf9b9e0292a6041256e5a4286a76cddc61
+DIST wmitime-0.4.tar.gz 21092 SHA256 aa4557833d2661d841befc0d3c0f940195af11c7a96802647907f5fe46a69846 SHA512 ae0d3d5942ec5258e69298874563c9faafbca63f60f6f57f1859bb58094fb6c64255bbf231b00208c58cb103229a9be8ea2ba60259cb5adb33105ea3a9c570ec WHIRLPOOL 4bf88a20512b294f46caa267a081a58dd70f33801ff926e5b44a9c3a9804e77c6a4936f557974e31ed9cd633feabef3c30f0ed1a9fd6be8c59ad554cd37bc66b
diff --git a/x11-plugins/wmitime/files/makefile.diff b/x11-plugins/wmitime/files/makefile.diff
new file mode 100644
index 000000000000..343c247a3ed5
--- /dev/null
+++ b/x11-plugins/wmitime/files/makefile.diff
@@ -0,0 +1,26 @@
+diff -urN wmitime/wmitime/Makefile wmitime-modified/wmitime/Makefile
+--- wmitime/wmitime/Makefile 1999-03-28 21:51:39.000000000 -0600
++++ wmitime-modified/wmitime/Makefile 2002-10-04 10:35:16.000000000 -0500
+@@ -1,7 +1,6 @@
+-#LANG = fr
+ LIBDIR = -L/usr/X11R6/lib
+ LIBS = -lXpm -lXext -lX11 -lm
+-FLAGS = -O2
++FLAGS = $(CFLAGS)
+ OBJS = wmitime.o \
+ ../wmgeneral/wmgeneral.o \
+ ../wmgeneral/misc.o \
+@@ -9,11 +8,10 @@
+
+
+ .c.o:
+- cc -I/usr/X11R6/share/include $(FLAGS) -D$(LANG) -c -Wall $< -o $*.o
++ gcc -I/usr/X11R6/share/include $(FLAGS) -c -Wall $< -o $*.o
+
+ wmtime: $(OBJS)
+- cc $(FLAGS) -D$(LANG) -o wmitime $^ -lXext $(LIBDIR) $(LIBS)
+-
++ gcc $(FLAGS) $(LDFLAGS) -o wmitime $^ -lXext $(LIBDIR) $(LIBS)
+ all:: wmtime
+
+ clean::
diff --git a/x11-plugins/wmitime/metadata.xml b/x11-plugins/wmitime/metadata.xml
new file mode 100644
index 000000000000..266d9a84f83a
--- /dev/null
+++ b/x11-plugins/wmitime/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>desktop-dock</herd>
+<longdescription>
+WMitime is an (overglorified) clock for the Windowmaker/Afterstep dock. It
+displays standard 12/24 hour time and date, as well as Swatch's new internet
+time.
+</longdescription>
+</pkgmetadata>
diff --git a/x11-plugins/wmitime/wmitime-0.3.ebuild b/x11-plugins/wmitime/wmitime-0.3.ebuild
new file mode 100644
index 000000000000..5c3b3814c763
--- /dev/null
+++ b/x11-plugins/wmitime/wmitime-0.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+S=${WORKDIR}/${PN}
+IUSE=""
+DESCRIPTION="Overglorified clock dockapp w/time, date, and internet time"
+HOMEPAGE="http://www.neotokyo.org/illusion/"
+SRC_URI="http://www.neotokyo.org/illusion/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 sparc x86"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/makefile.diff
+}
+
+src_compile() {
+ cd "${S}"/wmitime
+ make || die "make failed"
+}
+
+src_install() {
+ cd "${S}"/wmitime
+ dobin wmitime
+
+ cd "${S}"
+ dodoc BUGS CHANGES README
+}
diff --git a/x11-plugins/wmitime/wmitime-0.4.ebuild b/x11-plugins/wmitime/wmitime-0.4.ebuild
new file mode 100644
index 000000000000..f05b48a93ccd
--- /dev/null
+++ b/x11-plugins/wmitime/wmitime-0.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="Overglorified clock dockapp w/time, date, and internet time"
+HOMEPAGE="http://windowmaker.org/dockapps/?name=wmitime"
+# Grab from http://windowmaker.org/dockapps/?download=${P}.tar.gz
+SRC_URI="http://dev.gentoo.org/~voyageur/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/dockapps
+
+src_compile() {
+ emake CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr install
+
+ dodoc BUGS CHANGES README
+}