summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/asclock
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/asclock')
-rw-r--r--x11-plugins/asclock/Manifest1
-rw-r--r--x11-plugins/asclock/asclock-2.0.12-r1.ebuild65
-rw-r--r--x11-plugins/asclock/files/asclock-gcc41.patch44
-rw-r--r--x11-plugins/asclock/metadata.xml5
4 files changed, 115 insertions, 0 deletions
diff --git a/x11-plugins/asclock/Manifest b/x11-plugins/asclock/Manifest
new file mode 100644
index 000000000000..eaf50707d3ca
--- /dev/null
+++ b/x11-plugins/asclock/Manifest
@@ -0,0 +1 @@
+DIST asclock-2.0.12.tar.gz 111858 SHA256 70df9bd991bc707c0fdf76ea1acbeff5924e9ae0b0704feb46afa591030704e6
diff --git a/x11-plugins/asclock/asclock-2.0.12-r1.ebuild b/x11-plugins/asclock/asclock-2.0.12-r1.ebuild
new file mode 100644
index 000000000000..76db5622f674
--- /dev/null
+++ b/x11-plugins/asclock/asclock-2.0.12-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+inherit eutils toolchain-funcs
+
+IUSE=""
+DESCRIPTION="Clock applet for AfterStep"
+SRC_URI="http://www.tigr.net/afterstep/download/asclock/${P}.tar.gz"
+HOMEPAGE="http://tigr.net/afterstep/applets/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~mips ppc sparc x86 ~amd64-linux ~x86-linux ~x64-solaris"
+
+DEPEND="x11-libs/libXpm"
+RDEPEND="${DEPEND}
+ x11-proto/xextproto
+ x11-proto/xproto"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-gcc41.patch
+ ln -s themes/classic default_theme
+}
+
+src_configure() { :; }
+
+src_compile() {
+ local x
+ # will break Solaris
+ [[ ${CHOST} == *-linux-gnu ]] && CFLAGS="${CFLAGS} \
+ -Dlinux \
+ -D_POSIX_C_SOURCE=199309L \
+ -D_POSIX_SOURCE \
+ -D_XOPEN_SOURCE"
+ for x in asclock parser symbols config
+ do
+ $(tc-getCC) \
+ ${CPPFLAGS} ${CFLAGS} ${ASFLAGS} \
+ -I"${EPREFIX}"/usr/include \
+ -D_BSD_SOURCE \
+ -D_SVID_SOURCE \
+ -DFUNCPROTO=15 \
+ -DNARROWPROTO \
+ -c -o ${x}.o ${x}.c || die "compile asclock failed"
+ done
+ $(tc-getCC) \
+ ${LDFLAGS} \
+ -o asclock \
+ asclock.o parser.o symbols.o config.o \
+ -L"${EPREFIX}"/usr/lib \
+ -L"${EPREFIX}"/usr/lib/X11 \
+ -lXpm -lXext -lX11 || die "link asclock failed"
+}
+
+src_install() {
+ dobin asclock
+ local themesdir="/usr/share/${PN}/themes"
+ insinto ${themesdir}
+ doins -r themes/*
+ dodoc README README.THEMES TODO
+ cd "${D}"/${themesdir}
+ rm -f Freeamp/Makefile{,.*}
+ ln -s classic default_theme
+}
diff --git a/x11-plugins/asclock/files/asclock-gcc41.patch b/x11-plugins/asclock/files/asclock-gcc41.patch
new file mode 100644
index 000000000000..5a5291219ee5
--- /dev/null
+++ b/x11-plugins/asclock/files/asclock-gcc41.patch
@@ -0,0 +1,44 @@
+diff -ur asclock-2.0.12-orig/asclock.h asclock-2.0.12/asclock.h
+--- asclock-2.0.12-orig/asclock.h 2006-06-03 15:31:58.000000000 -0400
++++ asclock-2.0.12/asclock.h 2006-06-03 15:35:51.000000000 -0400
+@@ -38,15 +38,15 @@
+ #define INT_TYPE 0;
+
+ /* the xpm data */
+-extern char *clock_xpm[];
+-extern char *month_xpm[];
+-extern char *weekday_xpm[];
+-extern char *led_xpm[];
+-extern char *date_xpm[];
+-extern char *hour_xpm[];
+-extern char *minute_xpm[];
+-extern char *second_xpm[];
+-extern char *beats_xpm[];
++static char *clock_xpm[];
++static char *month_xpm[];
++static char *weekday_xpm[];
++static char *led_xpm[];
++static char *date_xpm[];
++static char *hour_xpm[];
++static char *minute_xpm[];
++static char *second_xpm[];
++static char *beats_xpm[];
+
+ /* the filenames */
+ extern char clock_xpm_fn[MAX_PATH_LEN];
+diff -ur asclock-2.0.12-orig/themes/classic/beats.xpm asclock-2.0.12/themes/classic/beats.xpm
+--- asclock-2.0.12-orig/themes/classic/beats.xpm 2006-06-03 15:31:58.000000000 -0400
++++ asclock-2.0.12/themes/classic/beats.xpm 2006-06-03 15:37:04.000000000 -0400
+@@ -1 +1 @@
+-char *beats_xpm[] = { NULL };
++static char *beats_xpm[] = { NULL };
+diff -ur asclock-2.0.12-orig/themes/classic/led.xpm asclock-2.0.12/themes/classic/led.xpm
+--- asclock-2.0.12-orig/themes/classic/led.xpm 2006-06-03 15:31:58.000000000 -0400
++++ asclock-2.0.12/themes/classic/led.xpm 2006-06-03 15:36:53.000000000 -0400
+@@ -1,5 +1,5 @@
+ /* XPM */
+-char * led_xpm[] = {
++static char * led_xpm[] = {
+ "135 11 3 1",
+ " c #282828",
+ "O c #00df00",
diff --git a/x11-plugins/asclock/metadata.xml b/x11-plugins/asclock/metadata.xml
new file mode 100644
index 000000000000..4538a68724a6
--- /dev/null
+++ b/x11-plugins/asclock/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+</pkgmetadata>