summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jordan <immoloism@gmail.com>2024-04-06 15:42:28 +0100
committerArthur Zamarin <arthurzam@gentoo.org>2024-04-09 20:19:22 +0300
commitc64cef037cbc69ae9c00427ae5e42bd55eab0e20 (patch)
tree7d18ec65c5bf0bb1f0298d0fdb9bccdc456eb8ac /x11-misc
parentx11-misc/mozo: drop 1.27.0 (diff)
downloadgentoo-c64cef037cbc69ae9c00427ae5e42bd55eab0e20.tar.gz
gentoo-c64cef037cbc69ae9c00427ae5e42bd55eab0e20.tar.bz2
gentoo-c64cef037cbc69ae9c00427ae5e42bd55eab0e20.zip
x11-misc/mozo: add 1.28.0
Signed-off-by: Ian Jordan <immoloism@gmail.com> Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/mozo/Manifest1
-rw-r--r--x11-misc/mozo/mozo-1.28.0.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/x11-misc/mozo/Manifest b/x11-misc/mozo/Manifest
index fb866f291ca4..7c89dca04af0 100644
--- a/x11-misc/mozo/Manifest
+++ b/x11-misc/mozo/Manifest
@@ -1 +1,2 @@
DIST mozo-1.26.2.tar.xz 249672 BLAKE2B 95e9a04fc91424e8ce95e870253bf1d2eddfbbf1b78b632b15d057a3ffa86068bb2c89442cfc50c4f74a76e75b345c6b06cf47d5891eed3ffce460697fb0094b SHA512 c4ea00f97f4dd5c9b33b78e1b438ba80a5e23b69d05f6ea59c522a580c1b07c280cddc0591f266c16f39bbe5f3e07ca28cdbd33753162a02584b551a9857b904
+DIST mozo-1.28.0.tar.xz 251512 BLAKE2B 79248acfb03bde54414399f832402cd40e05ccd6ea47ca239691b1c4856a301b5c20874399fa6e27ca098a73021ed4cd4fa573d94f4c2d9926c58257b29be0a8 SHA512 7576bcf275f3dc402db7a436094fe9e601529f5d9827c14b658caca82393ce71075977e523550ab15986eb32ff30718431dc6fcbbb6ae8e9d332ebb3f220beec
diff --git a/x11-misc/mozo/mozo-1.28.0.ebuild b/x11-misc/mozo/mozo-1.28.0.ebuild
new file mode 100644
index 000000000000..6496e4d89d96
--- /dev/null
+++ b/x11-misc/mozo/mozo-1.28.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit mate python-r1
+
+DESCRIPTION="Mozo menu editor for MATE"
+LICENSE="GPL-2+ GPL-3+ LGPL-2+ LGPL-2.1+"
+
+MINOR=$(($(ver_cut 2) % 2))
+if [[ ${MINOR} -eq 0 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+else
+ KEYWORDS=""
+fi
+
+SLOT="0"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="${PYTHON_DEPS}
+ >=dev-python/pygobject-3:3[${PYTHON_USEDEP}]
+ >=mate-base/mate-menus-1.21.0[introspection]
+ x11-libs/gdk-pixbuf:2[introspection]
+ >=x11-libs/gtk+-3.12:3[introspection]
+"
+
+RDEPEND="${COMMON_DEPEND}
+ virtual/libintl
+"
+DEPEND="${COMMON_DEPEND}
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ mate_src_prepare
+ python_copy_sources
+}
+
+src_configure() {
+ python_foreach_impl run_in_build_dir mate_src_configure \
+ --disable-icon-update
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir default
+}
+
+src_test() {
+ python_foreach_impl run_in_build_dir emake check
+}
+
+src_install() {
+ installing() {
+ mate_src_install
+
+ # Massage shebang to make python_doscript happy
+ sed -e 's:#! '"${PYTHON}:#!/usr/bin/python:" \
+ -i mozo || die
+
+ python_doscript mozo
+ python_optimize
+ }
+
+ python_foreach_impl run_in_build_dir installing
+}