summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-10-11 01:03:20 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-10-11 01:09:12 -0400
commit916f6b97fc1ea3d7c8539a3c740460f602591237 (patch)
treeab3294170acdb4d16f67c92594eb93df96ece4ae /x11-misc/xkeycaps
parentnet-misc/vncrec: further fix w/ upcoming clang16 (diff)
downloadgentoo-916f6b97fc1ea3d7c8539a3c740460f602591237.tar.gz
gentoo-916f6b97fc1ea3d7c8539a3c740460f602591237.tar.bz2
gentoo-916f6b97fc1ea3d7c8539a3c740460f602591237.zip
x11-misc/xkeycaps: further fix w/ upcoming clang16
When last tested this package, did not know clang16 was newly enabling -Werror=incompatible-pointer-types yet and hadn't looked at this. Trivial const mismatch, so no revbump. Bug: https://bugs.gentoo.org/871129 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-misc/xkeycaps')
-rw-r--r--x11-misc/xkeycaps/files/xkeycaps-2.47_p7-clang16.patch18
-rw-r--r--x11-misc/xkeycaps/xkeycaps-2.47_p7.ebuild1
2 files changed, 19 insertions, 0 deletions
diff --git a/x11-misc/xkeycaps/files/xkeycaps-2.47_p7-clang16.patch b/x11-misc/xkeycaps/files/xkeycaps-2.47_p7-clang16.patch
new file mode 100644
index 000000000000..99dc6f4ea827
--- /dev/null
+++ b/x11-misc/xkeycaps/files/xkeycaps-2.47_p7-clang16.patch
@@ -0,0 +1,18 @@
+https://bugs.gentoo.org/871129
+--- a/commands.c
++++ b/commands.c
+@@ -1754,3 +1754,3 @@
+ }
+- XawListChange (box->keysym_list, keysym_name_buffer, 0, 0, True);
++ XawListChange (box->keysym_list, (const char **) keysym_name_buffer, 0, 0, True);
+ }
+@@ -2528,3 +2528,3 @@
+ box->set = &keyboard_sets [i];
+- XawListChange (box->keymap_list, (char **) box->set->maps, 0, 0, True);
++ XawListChange (box->keymap_list, (const char **) box->set->maps, 0, 0, True);
+ for (i = 0; i < box->set->map_count; i++)
+@@ -2599,3 +2599,3 @@
+
+- XawListChange (box->keyboard_list, list, 0, 0, True);
++ XawListChange (box->keyboard_list, (const char **) list, 0, 0, True);
+ XawListHighlight (box->keyboard_list, kbd);
diff --git a/x11-misc/xkeycaps/xkeycaps-2.47_p7.ebuild b/x11-misc/xkeycaps/xkeycaps-2.47_p7.ebuild
index be540734790a..136ec95c516f 100644
--- a/x11-misc/xkeycaps/xkeycaps-2.47_p7.ebuild
+++ b/x11-misc/xkeycaps/xkeycaps-2.47_p7.ebuild
@@ -35,6 +35,7 @@ BDEPEND="
DOCS=( README defining.txt hierarchy.txt sgi-microsoft.txt )
PATCHES=(
"${FILESDIR}"/${P/_p*}-Imakefile.patch
+ "${FILESDIR}"/${P}-clang16.patch
)
S=${WORKDIR}/${P/_p*}