summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/fbpager
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/fbpager')
-rw-r--r--x11-misc/fbpager/Manifest1
-rw-r--r--x11-misc/fbpager/fbpager-20090221.ebuild32
-rw-r--r--x11-misc/fbpager/files/fbpager-0.1.4-gcc41.patch76
-rw-r--r--x11-misc/fbpager/files/fbpager-0.1.4-gcc43.patch63
-rw-r--r--x11-misc/fbpager/metadata.xml9
5 files changed, 181 insertions, 0 deletions
diff --git a/x11-misc/fbpager/Manifest b/x11-misc/fbpager/Manifest
new file mode 100644
index 000000000000..565261e38af7
--- /dev/null
+++ b/x11-misc/fbpager/Manifest
@@ -0,0 +1 @@
+DIST fbpager-20090221.tar.bz2 267876 SHA256 3120bee671b482cd0985e6bfe1ed63d4518f2b648dc0730861776db5c738d921 SHA512 fca9a43a3f71b1eb7b27befb3de4b0010f4974cb8898050325bec6def19f1b99a8e549eec04c14ef7777da8d23c25f8e799798160384e08d5a213c9c202bfd7a WHIRLPOOL b4cfe551b2c1b6e233c5243b8d1128ca1ed445bc670105688cf9141c60131d858bcd6d508160a258a102f0b466ddeea4e7ebf323e0c57da0afd1b529ba71f668
diff --git a/x11-misc/fbpager/fbpager-20090221.ebuild b/x11-misc/fbpager/fbpager-20090221.ebuild
new file mode 100644
index 000000000000..38d8762a053d
--- /dev/null
+++ b/x11-misc/fbpager/fbpager-20090221.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="A Pager for fluxbox"
+HOMEPAGE="http://git.fluxbox.org/fbpager.git/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~mips ppc ~sparc x86 ~x86-fbsd"
+IUSE="+xrender"
+
+DEPEND="x11-libs/libX11
+ xrender? ( x11-libs/libXrender )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf $(use_enable xrender)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS NEWS README TODO
+}
+
+pkg_postinst() {
+ einfo "To run fbpager inside the FluxBox slit, use fbpager -w"
+}
diff --git a/x11-misc/fbpager/files/fbpager-0.1.4-gcc41.patch b/x11-misc/fbpager/files/fbpager-0.1.4-gcc41.patch
new file mode 100644
index 000000000000..8f085d5a9724
--- /dev/null
+++ b/x11-misc/fbpager/files/fbpager-0.1.4-gcc41.patch
@@ -0,0 +1,76 @@
+--- fbpager-0.1.4.orig/src/Resources.hh
++++ fbpager-0.1.4/src/Resources.hh
+@@ -8,8 +8,10 @@
+ #include <cstdio>
+ #include <cstring>
+
++namespace FbTk {
++
+ template<>
+-void FbTk::Resource<bool>::
++void Resource<bool>::
+ setFromString(char const *strval) {
+ if (strcasecmp(strval, "true") == 0 ||
+ strcasecmp(strval, "yes") == 0)
+@@ -19,38 +21,37 @@
+ }
+
+ template<>
+-std::string FbTk::Resource<bool>::
++std::string Resource<bool>::
+ getString() {
+ return std::string(**this == true ? "true" : "false");
+ }
+
+ template <>
+-void FbTk::Resource<std::string>::setFromString(const char *str) {
++void Resource<std::string>::setFromString(const char *str) {
+ *(*this) = (str ? str : "");
+ }
+
+ template <>
+-std::string FbTk::Resource<std::string>::getString() {
++std::string Resource<std::string>::getString() {
+ return *(*this);
+ }
+
+ template <>
+-void FbTk::Resource<int>::setFromString(const char *str) {
++void Resource<int>::setFromString(const char *str) {
+ if (str == 0)
+ return;
+ sscanf(str, "%d", &(*(*this)));
+ }
+
+ template <>
+-std::string FbTk::Resource<int>::getString() {
++std::string Resource<int>::getString() {
+ char buff[16];
+ sprintf(buff, "%d", (*(*this)));
+ return std::string(buff);
+ }
+
+-namespace FbPager {
+ template <>
+-void FbTk::Resource<FbPager::Alignment>::setFromString(const char *str) {
++void Resource<FbPager::FbPager::Alignment>::setFromString(const char *str) {
+ if (strcmp("TopToBottom", str) == 0)
+ *(*this) = FbPager::FbPager::TOP_TO_BOTTOM;
+ else
+@@ -58,7 +59,7 @@
+ }
+
+ template <>
+-std::string FbTk::Resource<FbPager::Alignment>::getString() {
++std::string Resource<FbPager::FbPager::Alignment>::getString() {
+ switch (*(*this)) {
+ case FbPager::FbPager::LEFT_TO_RIGHT:
+ return "LeftToRight";
+@@ -67,6 +68,6 @@
+ }
+ }
+
+-} // end namespace FbPager
++} // end namespace FbTk
+
+ #endif // RESOURCES
diff --git a/x11-misc/fbpager/files/fbpager-0.1.4-gcc43.patch b/x11-misc/fbpager/files/fbpager-0.1.4-gcc43.patch
new file mode 100644
index 000000000000..9289e990bac4
--- /dev/null
+++ b/x11-misc/fbpager/files/fbpager-0.1.4-gcc43.patch
@@ -0,0 +1,63 @@
+--- src/FbTk/StringUtil.cc.orig 2008-06-14 17:36:06.000000000 +0000
++++ src/FbTk/StringUtil.cc 2008-06-14 17:39:56.000000000 +0000
+@@ -23,6 +23,9 @@
+
+ #include "StringUtil.hh"
+
++
++#include <cstring>
++#include <locale>
+ #include <string>
+ #include <cstdio>
+ #include <cstdlib>
+@@ -37,6 +40,26 @@
+
+ namespace StringUtil {
+
++
++/*
++ * structs needed for std::transform()
++ * See: http://gcc.gnu.org/onlinedocs/libstdc++/22_locale/howto.html#7
++ */
++struct ToUpper {
++ ToUpper(std::locale const& l) : loc(l) {;}
++ char operator() (char c) const { return std::toupper(c,loc); }
++ private:
++ std::locale const& loc;
++};
++
++struct ToLower {
++ ToLower(std::locale const& l) : loc(l) {;}
++ char operator() (char c) const { return std::tolower(c,loc); }
++private:
++ std::locale const& loc;
++};
++
++
+ /**
+ Takes a pointer to string *s as an argument,
+ creates a new string n, copies s to n and
+@@ -160,14 +183,20 @@
+ }
+
+ std::string toLower(const std::string &conv) {
++
++ ToLower __tolower(std::locale::classic());
++
+ std::string ret = conv;
+- std::transform(ret.begin(), ret.end(), ret.begin(), tolower);
++ std::transform(ret.begin(), ret.end(), ret.begin(), __tolower);
+ return ret;
+ }
+
+ std::string toUpper(const std::string &conv) {
++
++ ToUpper __toupper(std::locale::classic());
++
+ std::string ret = conv;
+- std::transform(ret.begin(), ret.end(), ret.begin(), toupper);
++ std::transform(ret.begin(), ret.end(), ret.begin(), __toupper);
+ return ret;
+ }
+
+
diff --git a/x11-misc/fbpager/metadata.xml b/x11-misc/fbpager/metadata.xml
new file mode 100644
index 000000000000..2deafa5692f4
--- /dev/null
+++ b/x11-misc/fbpager/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+ <use>
+ <flag name='xrender'>Enable transparency support via
+ <pkg>x11-libs/libXrender</pkg></flag>
+ </use>
+</pkgmetadata>