summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2024-11-10 14:29:54 -0500
committerMatt Turner <mattst88@gentoo.org>2024-11-10 14:31:03 -0500
commit85e50c9470ba85564347bdc7c51f5327308ae998 (patch)
tree67c6ab68be8384bb51fa96d845a95e0c9af2698b /x11-libs
parentsys-process/btop: Keyword 1.4.0 for ~m68k (diff)
downloadgentoo-85e50c9470ba85564347bdc7c51f5327308ae998.tar.gz
gentoo-85e50c9470ba85564347bdc7c51f5327308ae998.tar.bz2
gentoo-85e50c9470ba85564347bdc7c51f5327308ae998.zip
x11-libs/xtrans: Version bump to 1.5.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/xtrans/Manifest1
-rw-r--r--x11-libs/xtrans/xtrans-1.5.2.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/x11-libs/xtrans/Manifest b/x11-libs/xtrans/Manifest
index aad5ee4d6caa..1680291dab2a 100644
--- a/x11-libs/xtrans/Manifest
+++ b/x11-libs/xtrans/Manifest
@@ -1,2 +1,3 @@
DIST xtrans-1.5.0.tar.xz 170388 BLAKE2B a07dc501a36f4a6d7d9c407c36c5fcaa9555eeec3066d91fa8531118ac04bc55a1fbdce6370782aa8a18e1f26b14e3ad644e1e98ae3a353234e3ecae71fe065b SHA512 e8091f11d4ad2b14e01de3eac56bdf2267ea26687ce66e3056374d0d02e049480c0b27c482f8828a0efd086f1e4c485108ca4dce3f83d66c1896effa3b38b228
DIST xtrans-1.5.1.tar.xz 175624 BLAKE2B 5ab6ffdc0028da16b4373f824c9bfc51db9bb90bc593c101b2647496846687fd020423e4eb204e8b261fa39123f5a57338b9257b13b7abb92e8d1a49cd3c3345 SHA512 1a4bf3495ba401711b632972acf26bb82c2e8fd917a868ed21e510a1bb1ec57c145496baddb44de76e00c2d03dbf9e8592099623da4c065de3a7c5a804e87c1e
+DIST xtrans-1.5.2.tar.xz 176680 BLAKE2B 6381257bfc489767438e76afe9bab5e9f143e7524417de0396c0d04e42f1ee7ef28cec6fee83a68f60d3d82326c824f1baa9e58c47f7108e4a4d5dc9a2daa65a SHA512 4c4909402cb7df0d69bf2801722de822f7e376d585ff5aa8db8f88be77ed7fb7dfbdc410827069fc5041327e81afeb9d403c6c92e5c1e02d593c829ef6c37536
diff --git a/x11-libs/xtrans/xtrans-1.5.2.ebuild b/x11-libs/xtrans/xtrans-1.5.2.ebuild
new file mode 100644
index 000000000000..6555ce70c0bc
--- /dev/null
+++ b/x11-libs/xtrans/xtrans-1.5.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_PACKAGE_NAME="lib${PN}"
+# this package just installs some .c and .h files, no libraries
+XORG_DOC=doc
+XORG_TARBALL_SUFFIX="xz"
+inherit xorg-3
+
+DESCRIPTION="X.Org xtrans library"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ $(use_enable doc docs)
+ $(use_with doc xmlto)
+ --without-fop
+ )
+ xorg-3_src_configure
+}