summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2024-11-05 12:23:04 -0500
committerMatt Turner <mattst88@gentoo.org>2024-11-05 12:27:23 -0500
commit3889a4c90a0abb162a720967311764234679960a (patch)
tree0fce0ff386cfa4ec1cbac11b7ed524a9065dcfb6 /x11-libs
parentx11-libs/pixman: Bump to EAPI=8 (diff)
downloadgentoo-3889a4c90a0abb162a720967311764234679960a.tar.gz
gentoo-3889a4c90a0abb162a720967311764234679960a.tar.bz2
gentoo-3889a4c90a0abb162a720967311764234679960a.zip
x11-libs/pixman: Version bump to 0.44.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/pixman/Manifest1
-rw-r--r--x11-libs/pixman/pixman-0.44.0.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/x11-libs/pixman/Manifest b/x11-libs/pixman/Manifest
index df5657790619..d39b17019948 100644
--- a/x11-libs/pixman/Manifest
+++ b/x11-libs/pixman/Manifest
@@ -1 +1,2 @@
DIST pixman-0.43.4.tar.xz 636900 BLAKE2B c31e5700bfadcd72f522af50509a4a6cd7bbf90c918c75b108e50246f1c76e858125138902a222040ada192710ec788deb43eb65085416f3eff88e3ed970933e SHA512 b40fb05bd58dc78f4e4e9b19c86991ab0611b708657c9a7fb42bfe82d57820a0fde01a34b00a0848a41da6c3fb90c2213942a70f435a0e9467631695d3bc7e36
+DIST pixman-0.44.0.tar.xz 649200 BLAKE2B ea3f5fc5e6febfd3e6acf89b9bb7ce2d7c82d42ede2b3f7df69ce6d65ec2d75d3402523a1a3227135caac34633556dec3010a435ace23f2c8255ea210c03d5db SHA512 3ea293cd308a4faeb600939df2c98148154cf1faf8e435b9f33df46c33acfeb32572cb0c1e148ee9f6f39f9e8a49fbda627edcac03da2000d89e22941849a04d
diff --git a/x11-libs/pixman/pixman-0.44.0.ebuild b/x11-libs/pixman/pixman-0.44.0.ebuild
new file mode 100644
index 000000000000..456ea42b8574
--- /dev/null
+++ b/x11-libs/pixman/pixman-0.44.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+EGIT_REPO_URI="https://gitlab.freedesktop.org/pixman/pixman.git"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-r3"
+fi
+
+inherit ${GIT_ECLASS} meson-multilib multiprocessing toolchain-funcs
+
+DESCRIPTION="Low-level pixel manipulation routines"
+HOMEPAGE="http://www.pixman.org/ https://gitlab.freedesktop.org/pixman/pixman/"
+if [[ ${PV} != 9999* ]]; then
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+ SRC_URI="https://www.x.org/releases/individual/lib/${P}.tar.xz"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="cpu_flags_ppc_altivec cpu_flags_arm_neon loongson2f cpu_flags_x86_mmxext cpu_flags_x86_sse2 cpu_flags_x86_ssse3 static-libs test"
+RESTRICT="!test? ( test )"
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use test && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use test && tc-check-openmp
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ $(meson_feature cpu_flags_x86_mmxext mmx)
+ $(meson_feature cpu_flags_x86_sse2 sse2)
+ $(meson_feature cpu_flags_x86_ssse3 ssse3)
+ $(meson_feature cpu_flags_ppc_altivec vmx)
+ $(meson_feature loongson2f loongson-mmi)
+ $(meson_feature test openmp) # only used in unit tests
+ $(meson_feature test tests)
+ -Ddefault_library=$(usex static-libs both shared)
+ -Ddemos=disabled
+ -Dgtk=disabled
+ -Dlibpng=disabled
+ )
+
+ if [[ ${ABI} == arm64 ]]; then
+ emesonargs+=($(meson_feature cpu_flags_arm_neon a64-neon))
+ elif [[ ${ABI} == arm ]]; then
+ emesonargs+=($(meson_feature cpu_flags_arm_neon neon))
+ fi
+
+ meson_src_configure
+}
+
+multilib_src_test() {
+ export OMP_NUM_THREADS=$(makeopts_jobs)
+ meson_src_test -t 100
+}